Configuracion de ThunderCache 3.1.2 paralelo a Mikrotik - Squid 3.x

Tema en '[ThunderCache] Otros Sistemas' iniciado por davidcito, 14 Nov 2012.

  1. coldstriker

    coldstriker Member

    Me Gusta recibidos:
    0
    estan hablando de thundercache? o de otro sistema similar.
     
  2. kr4ken88

    kr4ken88 Member

    Me Gusta recibidos:
    17
    halcon543 Efectivamente es Squid 3.x, lo tengo funcionando hace aprox. 5 meses con 3 discos de 2 TB c/u.

    coldstriker Yo estoy hablando de Thunder 3.1.2

    Saludoss
     
    Última edición por un moderador: 27 Mar 2014
    A Manuel Alvarez le gusta esto.
  3. halcon543

    halcon543 Member

    Me Gusta recibidos:
    1
    en ese tiempo 5 meses cuanto lleva de cache para tener 150 clientes
     
  4. halcon543

    halcon543 Member

    Me Gusta recibidos:
    1
    Tengo instalado el thunder 3.1.2 con squid 3x hasta ahora funciona bien pero no veo que se reinicia automatico como la otra version con squid 2.7 donde puedo modificar eso
     
    A Manuel Alvarez le gusta esto.
  5. ciber

    ciber Member

    Me Gusta recibidos:
    6
    amigo halcon543 me podrias pasar algun manual para instalar thunder 3.1.2 con swuid 3x no encuentro un manual k este fnucionando por fa te agradesco mucho
     
    A Manuel Alvarez le gusta esto.
  6. kuichines

    kuichines New Member

    Me Gusta recibidos:
    0
  7. Shadowofvilla

    Shadowofvilla New Member

    Me Gusta recibidos:
    0
    ese problema yo tambien tengo y al final que ip le cambiaste???
     
  8. ramirez

    ramirez Member

    Me Gusta recibidos:
    1
    Hola davidcito Donde puedo descargar la versión de thunder 3.1.2 y tendrás algún manual para su instalación estoy interesado a experimentar como funciona.
     
    Última edición por un moderador: 27 Mar 2014
  9. ramirez

    ramirez Member

    Me Gusta recibidos:
    1
    Hola buenas noches necesito ayuda para configurar ThunderReport 3.2.1 no puedo hacer cache ya llebo dos dias y no me sale e reinstalado varias veces y nada.


    [​IMG]



    [​IMG]




    [​IMG]




    [​IMG]




    [​IMG]





    #=========================== Squid 3.x Conf =============================#

    #=================== Para uso con ThunderCache ===================#

    # Opciones de SQUID 3.x
    #----------------------------------------------------------------------
    http_port 3128 intercept
    visible_hostname proxy.routero-os.com
    icp_port 0
    #----------------------------------------------------------------------
    #error_directory /usr/share/squid3/errors/Spanish/
    #----------------------------------------------------------------------
    acl denegados url_regex -i "/etc/squid3/denegados.lst"
    #----------------------------------------------------------------------
    # Servidor DNS y Politica de Cambios
    #----------------------------------------------------------------------
    dns_nameservers 8.8.8.8 8.8.4.4
    dns_retransmit_interval 5 seconds
    dns_timeout 2 minutes
    #----------------------------------------------------------------------
    acl manager proto cache_object
    acl localhost src 127.0.0.1/32 ::1
    acl to_localhost dst 127.0.0.0/8 0.0.0.0/32 ::1
    acl CONNECT method CONNECT

    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl SSL_ports port 443
    acl Safe_ports port 443 # https
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl Safe_ports port 631 # cups
    acl Safe_ports port 873 # rsync
    acl Safe_ports port 901 # SWAT
    acl Safe_ports port 1863 # MSN
    #acl SSL_ports port 443 # https
    acl SSL_ports port 563 # snews
    acl SSL_ports port 873 # rsync

    http_access allow manager localhost
    http_access deny manager all
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow localhost
    http_access deny denegados
    #----------------------------------------------------------------------
    coredump_dir /var/spool/squid3
    #----------------------------------------------------------------------
    # Memoria reservada para cache
    # Se recomienda que dedique aprox. 5MB de RAM por cada 1GB asignado a cache_dir
    #----------------------------------------------------------------------
    cache_mem 512 MB
    #----------------------------------------------------------------------
    # Maximo tamaño de archivo en cache de memoria
    #----------------------------------------------------------------------
    maximum_object_size_in_memory 128 KB
    #----------------------------------------------------------------------
    # Maximo y minimo tamaño de archivos cache en el Disco duro
    #----------------------------------------------------------------------
    maximum_object_size 30 MB
    minimum_object_size 0 KB
    #----------------------------------------------------------------------
    # Sustituir archivos de cache cuando llegue a 96%
    #----------------------------------------------------------------------
    cache_swap_low 92
    cache_swap_high 96
    #----------------------------------------------------------------------
    # Total de espacio en HD a ser usado por el cache, numero de carpetas,
    # numero de subcarpetas en cache
    # 100000 = 100 GB
    #----------------------------------------------------------------------
    cache_dir aufs /var/spool/squid3/cache1 100000 16 256
    #----------------------------------------------------------------------
    # Estandar de actualización de cache
    # 1 mes = 10080 mins, 1 dia = 1440 mins
    #----------------------------------------------------------------------
    refresh_pattern -i \.jpg$ 14400 80% 43200 reload-into-ims
    refresh_pattern -i \.gif$ 14400 80% 43200 reload-into-ims
    refresh_pattern -i \.png$ 14400 80% 43200 reload-into-ims
    refresh_pattern -i \.jpeg$ 14400 80% 43200 reload-into-ims
    refresh_pattern -i \.bmp$ 14400 80% 43200 reload-into-ims
    refresh_pattern -i \.tif$ 14400 80% 43200 reload-into-ims
    refresh_pattern -i \.tiff$ 14400 80% 43200 reload-into-ims
    refresh_pattern -i \.swf$ 14400 80% 43200 reload-into-ims
    refresh_pattern -i \.html$ 10 20% 4320 reload-into-ims
    refresh_pattern -i \.htm$ 10 20% 4320 reload-into-ims
    refresh_pattern -i \.shtml$ 10 20% 4320 reload-into-ims
    refresh_pattern -i \.shtm$ 10 20% 4320 reload-into-ims
    refresh_pattern -i \.nub$ 2880 80% 21600 reload-into-ims
    refresh_pattern -i \.exe$ 14400 80% 43200
    refresh_pattern -i \.zip$ 14400 80% 43200
    refresh_pattern -i \.mov$ 14400 80% 43200
    refresh_pattern -i \.mpe?g?$ 14400 80% 43200
    refresh_pattern -i \.avi$ 14400 80% 43200
    refresh_pattern -i \.qtm?$ 14400 80% 43200
    refresh_pattern -i \.viv$ 14400 80% 43200
    refresh_pattern -i \.wav$ 14400 80% 43200
    refresh_pattern -i \.aiff?$ 14400 80% 43200
    refresh_pattern -i \.au$ 14400 80% 43200
    refresh_pattern -i \.ram?$ 14400 80% 43200
    refresh_pattern -i \.snd$ 14400 80% 43200
    refresh_pattern -i \.mid$ 14400 80% 43200
    refresh_pattern -i \.mp2$ 14400 80% 43200
    refresh_pattern -i \.mp3$ 14400 80% 43200
    refresh_pattern -i \.sit$ 14400 80% 43200
    refresh_pattern -i \.zip$ 14400 80% 43200
    refresh_pattern -i \.hqx$ 14400 80% 43200
    refresh_pattern -i \.arj$ 14400 80% 43200
    refresh_pattern -i \.lzh$ 14400 80% 43200
    refresh_pattern -i \.lha$ 14400 80% 43200
    refresh_pattern -i \.cab$ 14400 80% 43200
    refresh_pattern -i \.rar$ 14400 80% 43200
    refresh_pattern -i \.tar$ 14400 80% 43200
    refresh_pattern -i \.gz$ 14400 80% 43200
    refresh_pattern -i \.z$ 14400 80% 43200
    refresh_pattern -i \.a[0-9][0-9]$ 14400 80% 43200
    refresh_pattern -i \.r[0-9][0-9]$ 14400 80% 43200
    refresh_pattern -i \.txt$ 14400 80% 43200
    refresh_pattern -i \.pdf$ 14400 80% 43200
    refresh_pattern -i \.doc$ 14400 80% 43200
    refresh_pattern -i \.rtf$ 14400 80% 43200
    refresh_pattern -i \.tex$ 14400 80% 43200
    refresh_pattern -i \.latex$ 14400 80% 43200
    refresh_pattern -i \.class$ 14400 80% 43200
    refresh_pattern -i \.js$ 14400 80% 43200
    refresh_pattern -i \.ico$ 14400 80% 43200
    refresh_pattern -i \.css$ 10 20% 4320
    #----------------------------------------------------------------------
    refresh_pattern ^ftp: 1440 20% 10080
    refresh_pattern ^gopher: 1440 0% 1440
    refresh_pattern -i (/cgi-bin/|\?) 0 0% 0
    #refresh_pattern (Release|Package(.gz)*)$ 0 20% 2880
    refresh_pattern . 0 20% 4320
    #----------------------------------------------------------------------
    # Log de acessos por el cache o para SARG
    #----------------------------------------------------------------------
    logfile_rotate 7
    access_log /var/log/squid3/access.log
    access_log /var/log/squid3/error.log
    cache_store_log none
    #----------------------------------------------------------------------
    # Otras configuraciones
    #----------------------------------------------------------------------
    half_closed_clients off
    server_persistent_connections off
    client_persistent_connections off
    log_fqdn off
    quick_abort_min 0 KB
    quick_abort_max 0 KB
    quick_abort_pct 95
    max_filedescriptors 65536
    cache_effective_user proxy
    cache_effective_group proxy
    #----------------------------------------------------------------------
    # Manteniendo objetos recientes y pequeños en memoria
    #----------------------------------------------------------------------
    memory_replacement_policy heap GDSF
    cache_replacement_policy heap LFUDA
    #----------------------------------------------------------------------
    # Sitios que se les niega el cache
    #----------------------------------------------------------------------
    acl nocache dstdomain .4shared.com .youtube.com .windowsupdate.com .gl$
    no_cache deny nocache
    #----------------------------------------------------------------------
    # Negar cache para archivos con extencion .asx e .asf |streaming|
    #----------------------------------------------------------------------
    acl asx url_regex -i \.asx$
    cache deny asx
    acl asf url_regex -i \.asf$
    cache deny asf
    #----------------------------------------------------------------------
    #Redireccionamiento Thunder - REGEx
    #----------------------------------------------------------------------
    acl thunder_lst url_regex -i "/etc/thunder/thunder.lst"
    cache deny thunder_lst
    cache_peer 192.168.88.227 parent 8080 0 proxy-only no-digest
    dead_peer_timeout 2 seconds
    cache_peer_access 192.168.88.227 allow thunder_lst
    cache_peer_access 192.168.88.227 deny all
    #----------------------------------------------------------------------




    Del mikrotik la configuracion que pondre es este. Lo unico que no entiendo es este el numero 3 src-address=192.168.10.0/30



    1. /ip firewall filter

    2. add action=accept chain=forward comment="Acepta thunder 3.1.x" disabled=no \

    3. src-address=192.168.10.0/30

    4. /ip firewall nat

    5. add action=dst-nat chain=dstnat comment="Redirect Thunder 3.1.x" disabled=no \

    6. dst-port=80 protocol=tcp src-address=!192.168.88.227 to-addresses=\

    7. 192.168.10.2 to-ports=3128

    8. /ip firewall mangle

    9. add action=mark-connection chain=postrouting comment="THUNDER CACHE FULL(TC 3.\

    10. 1.x) =======================================================================\

    11. ===============================" content="X-Cache: HIT from Thunder" \

    12. disabled=no new-connection-mark=thunder-connection passthrough=yes \

    13. protocol=tcp src-address=192.168.88.227

    14. add action=mark-packet chain=postrouting connection-mark=thunder-connection \

    15. disabled=no new-packet-mark=thunder-packs passthrough=yes

    16. add action=mark-connection chain=postrouting comment="(TC 3.1.x)=========\

    17. ==========================================================================\

    18. ==================================" content="X-Cache: HIT from proxy.routero-os.com" \

    19. disabled=no new-connection-mark=proxy-hits passthrough=yes src-address=192.168.88.227\

    20. protocol=tcp

    21. add action=mark-packet chain=postrouting connection-mark=proxy-hits disabled=\

    22. no new-packet-mark=proxy-squid passthrough=yes

    23. /queue tree

    24. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \

    25. max-limit=4M name="T-cache_hits" packet-mark=proxy-squid parent=\

    26. global-out priority=4 queue=default

    27. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \

    28. max-limit=4M name=ThunderCache packet-mark=thunder-packs parent=\

    29. global-out priority=4 queue=default
     
    Última edición por un moderador: 18 Feb 2015
  10. deyhei

    deyhei New Member

    Me Gusta recibidos:
    0
    alguien me puede pasar el instalador por favor se los agradecería mucho
     
  11. deyhei

    deyhei New Member

    Me Gusta recibidos:
    0
    por favor
     
  12. deyhei

    deyhei New Member

    Me Gusta recibidos:
    0
    y feliz dìa del trabajador
     

Compartir esta página