Certificación MikroTik

MikroTik RD1100, doble internet, ¿cómo hago para conectar un softphone desde Internet

Tema en 'MikroTik RouterBOARD' iniciado por lcortes68, 28 Ago 2012.

  1. lcortes68

    lcortes68 New Member

    Me Gusta recibidos:
    0
    Tengo un router MikroTik RD1100, dos accesos a internet habilitados, cada uno con su propia dirección publica, ¿cómo hago para acceder desde un softphone a una planta asterisk desde Internet?, en el menu Ip/Firewall/nat ya agregue las reglas para los puertos que maneja dicha planta pero no he podido conectar y softphone externo a la planta
     
  2. ngnperu

    ngnperu Member

    Me Gusta recibidos:
    0
    Última edición por un moderador: 28 Mar 2014
  3. lcortes68

    lcortes68 New Member

    Me Gusta recibidos:
    0
    ngnperu, gracias por tu colaboración, las preguntas son las siguientes, 1.-¿estas ordenes las debo hacer por cada uno de mis servicios en internet? cada uno de mis servicios de internet tiene su propia ip pública ya que los servicios son de diferentes compañias; 2.-¿tu sabes como hago para que en el softphone externo sea transparente el conectarse a la planta?, la idea de tener dos servicios independientes de la Internet es para redundancia en caso que me falle uno el segundo entre en servicio y asi tener en un 99% acceso a la Internet, perdona las molestia pero soy nuevo en esto de los routers MT, gracias de atemano
     
  4. ryohnosuke

    ryohnosuke MikroTik Support Guy Administrador

    Me Gusta recibidos:
    202
    Sería excelente si publicas gráficas, y la regla de NAT que estás utilizando.

    Saludos.
     
  5. ngnperu

    ngnperu Member

    Me Gusta recibidos:
    0
    El esquema seria (softphone)--(internet)<-------->(2 lineas de internet)--(mikrotik)--(PBX) tus 2 servicios de internet estarian conectados a un router mikrotik donde esta tu servidor asterisk.
    - De echo que asterisk tiene que responder a un ip publico fijo, entonces al tener 2 ips publicos tendras que poner las reglas efectivamente para cada una de tus ips publicas en el MK deonde este tu PBX.
    - Del lado del sofphone solo necesitas poner el ip publico donde esta tu PBX para que se pueda registrar nada mas.
     
  6. lcortes68

    lcortes68 New Member

    Me Gusta recibidos:
    0
    si señor ngnperu ese es el esquema que necesito, ya hice los cambios en el firewall guandome por el enlaces de arriba pro aun no puedo conectar el softphone externo a mi red lan....no se como solucionarlo....te agradezco de antemano por tu ayuda...ANEXO IMPORTACION DE LAS REGLAS



    [ros]/ip firewall nat
    add action=masquerade chain=srcnat comment="Enrutamiento Telmex" disabled=no out-interface=ether1_Telmex
    add action=masquerade chain=srcnat comment="Enrutamiento Telefonica" disabled=no out-interface=Ether2_Telefonica
    add action=dst-nat chain="dstnat Asterisk" comment="Regla Base DNAT Asterisk" disabled=no dst-address=19X.XXX.XX.XXX dst-port=22 in-interface=Ether2_Telefonica protocol=\
    tcp to-addresses=192.168.XX.XXX to-ports=22
    add action=dst-nat chain="dstnat Asterisk" comment="Regla Base DNAT Asterisk" disabled=no dst-address=19X.XXX.XX.XXX dst-port=80 in-interface=ether1_Telmex protocol=tcp \
    to-addresses=192.168.XX.XXX to-ports=80
    add action=dst-nat chain="dstnat Asterisk" comment="Regla Base DNAT Asterisk" disabled=no dst-address=19X.XXX.XX.XXX dst-port=80 in-interface=Ether2_Telefonica protocol=\
    tcp to-addresses=192.168.XX.XXX to-ports=80
    add action=src-nat chain=srcnat disabled=no out-interface=Ether2_Telefonica protocol=udp src-address=192.168.XX.XXX src-port=5060-5065 to-addresses=19X.XXX.XX.XXX \
    to-ports=5060-5065
    add action=dst-nat chain="dstnat Asterisk" comment=VoIP disabled=no dst-address=19X.XXX.XX.XXX dst-port=5060-5065 in-interface=ether1_Telmex protocol=udp to-addresses=\
    192.168.XX.XXX to-ports=5060-5065
    add action=dst-nat chain="dstnat Asterisk" comment=VoIP disabled=no dst-address=19X.XXX.XX.XXX dst-port=10000-20000 in-interface=ether1_Telmex protocol=udp to-addresses=\
    190.168.55.187 to-ports=10000-20000
    add action=src-nat chain=srcnat disabled=no out-interface=ether1_Telmex protocol=udp src-address=192.168.XX.XXX src-port=10000-20000 to-addresses=19X.XXX.XX.XXX \
    to-ports=10000-20000
    add action=dst-nat chain="dstnat Asterisk" comment=VoIP disabled=no dst-address=19X.XXX.XX.XXX dst-port=5060-5065 in-interface=Ether2_Telefonica protocol=udp \
    to-addresses=192.168.XX.XXX to-ports=5060-5065
    add action=src-nat chain=srcnat disabled=no out-interface=Ether2_Telefonica protocol=udp src-address=192.168.XX.XXX src-port=5060-5065 to-addresses=19X.XXX.XX.XXX \
    to-ports=5060-5065
    add action=dst-nat chain="dstnat Asterisk" comment=VoIP disabled=no dst-address=19X.XXX.XX.XXX dst-port=10000-20000 in-interface=Ether2_Telefonica protocol=udp \
    to-addresses=192.168.XX.XXX to-ports=10000-20000
    add action=src-nat chain=srcnat disabled=no out-interface=ether1_Telmex protocol=udp src-address=192.168.XX.XXX src-port=10000-20000 to-addresses=19X.XXX.XX.XXX to-ports=\
    10000-20000[/ros]
     
    Última edición por un moderador: 31 Ago 2012
  7. ngnperu

    ngnperu Member

    Me Gusta recibidos:
    0
    trata de poner a tus modem como "bridge" para que mikrotik maneje directamente tu ip publica, sino tendrias que hacer un "port forwarding" a tu router telmex o telefonic hacia el ip de mikrotik con lo cual conseguirias que se registre el softphone desde "afuera" pero derrepente no llegue a pasar el audio asi que trata de hacer lo primero.

    adicional a eso tienes que editar el archivo sip_nat.conf para que puedan registrarse desde afuera asi:

    nat=yes
    externip=ip publico
    localnet=192.168.X.X/255.255.255.0 (ip lan)

    Saludos.
     
  8. lcortes68

    lcortes68 New Member

    Me Gusta recibidos:
    0
    como te comente anteriormente soy novato en esto de los routers MT como hago para poner mis modem como "bridge", existe unos comandos o algo asi???
    le agradezco de antemano...
     
  9. ngnperu

    ngnperu Member

    Me Gusta recibidos:
    0
    Última edición por un moderador: 28 Mar 2014
  10. lcortes68

    lcortes68 New Member

    Me Gusta recibidos:
    0
    ngnperu buenos dias....en mis servicios de internet no me piden clave para accesar a ellos, las empresas me entregan un modem el cual me da acceso a la internet
     
  11. ngnperu

    ngnperu Member

    Me Gusta recibidos:
    0
    de q pais eres ? tienes telefonica ? tienes adsl,fibra o wimax? de que marca es tu modem?
     
  12. lcortes68

    lcortes68 New Member

    Me Gusta recibidos:
    0
    ngnperu, estoy en colombia, mis servicios ambos son Adsl, el servicio de Telmex (ahora Claro) el moden es un Thomson modelo DWG849 y el de telefonica es un modem con el logo de la empresa pero en la plaqueta del seria dice marca ZTE modelo W300
     

Compartir esta página