Configurar ThunderCache como Parent Proxy de MikroTik

Tema en 'Guías y Manuales' iniciado por ryohnosuke, 26 Mar 2011.

  1. ryohnosuke

    ryohnosuke MikroTik Support Guy Administrador

    Me Gusta recibidos:
    122
    Ya vimos como configurar MikroTik para redireccionar el tráfico http de nuestros clientes hacia ThunderCache (Proxy Paralelo), ahora veremos cómo configurar el WebProxy de MikroTik para que use a ThunderCache como un Parent Proxy. El único beneficio de utilizar esta configuración es que podremos usar el Acces List del webproxy para bloquear páginas, redireccionar, etc.

    Tener en cuenta que al hacer esta config, MikroTik simplemente hará de intermediario entre los clientes y thundercache, sin almacenar ningún elemento por su cuenta, ya que thundercache se encargará de esto, tanto para elementos estáticos como dinámicos.

    Primer Caso: ThunderCache conectado al switch general de los clientes.

    Esta forma de 'acoplar' Thunder a MikroTik no la recomiendo del todo ya que si llegaramos a tener más de 60 clientes conectados podríamos notar una falta de rendimiento. Este caso sólo es recomendable cuando no tengamos la posibilidad de agregar una tarjeta exclusiva para el servidor ThunderCache.

    [​IMG]

    1.-Configuramos WebProxy para activar el Parent Proxy, esto lo vemos en IP -> WebProxy -> botón WebProxy Settings.

    [​IMG]

    Port, es el puerto de escucha del webproxy de MikroTik, lo cambiaremos a 8000, ya que el típico puerto 8080, también lo usa thunder, así que nos evitamos problemas cambiando el puerto.

    Parent Proxy, colocamos el IP de nuestro servidor ThunderCache, del ejemplo, 192.168.10.200

    Parent Proxy Port, colocamos el puerto de escucha de ThunderCache, en este caso es 3128.

    2.-Iniciamos la redirección al servidor ThunderCache.

    CODE, HTML o PHP Insertado:
    /ip firewall nat
    add chain=dstnat comment="Redireccion a Thunder" protocol=tcp dst-port=80 in-interface=LAN src-address=!192.168.10.200 action=redirect disabled=no to-ports=8000
    Segundo Caso: MikroTik con tarjeta de red exclusiva para Thunder. (Recomendado)

    Esta es la manera que recomiendo ya que se puede trabajar muy ordenadamente, además de no tener pérdida de rendimiento como en el Primer Caso. Notarán que aquí se utiliza una tarjeta dedicada en exclusividad a ThunderCache. En este caso la ether se llama THUNDER.

    [​IMG]

    1.-Configuramos WebProxy para activar el Parent Proxy, esto lo vemos en IP -> WebProxy -> botón WebProxy Settings.

    [​IMG]

    Port, es el puerto de escucha del webproxy de MikroTik, lo cambiaremos a 8000, ya que el típico puerto 8080, también lo usa thunder, así que nos evitamos problemas cambiando el puerto.

    Parent Proxy, colocamos el IP de nuestro servidor ThunderCache, del ejemplo, 192.168.2.2

    Parent Proxy Port, colocamos el puerto de escucha de ThunderCache, en este caso es 3128.

    1.-Asignamos un IP a la tarjeta donde conectaremos a nuestro servidor, que será la puerta de enlace por donde ThunderCache saldrá a internet.

    CODE, HTML o PHP Insertado:
    /ip address 
    add address=192.168.2.1/24 interface=THUNDER
    2.-Iniciamos la redirección al servidor ThunderCache.

    CODE, HTML o PHP Insertado:
    /ip firewall nat
    add action=dst-nat chain=dstnat comment="Redireccion a Thunder" dst-port=80 in-interface=LAN protocol=tcp to-ports=8000
    Saludos.
    Última edición: 27 Mar 2014
  2. ibrahim1985

    ibrahim1985 New Member

    Me Gusta recibidos:
    0
    Uff gracias Ryo, se te agradece esa hermano! Pero que es mejor; tenerlo como paralelo o como parent? tal vez como paralelo cierto? Saludos!
  3. ryohnosuke

    ryohnosuke MikroTik Support Guy Administrador

    Me Gusta recibidos:
    122
    La ventaja de tenerlo en Parent es que puedes usar el Access List de MikroTik para hacer los bloqueos y redirecciones de las páginas... Estarás detrás de 2 proxys, MikroTik webproxy y thundercache... el problema sería el WebProxy de MikroTik, que tiene la 'gracia' de generar bastaaantes conexiones simultáneas para comprobar el cache, pero al estar junto con thunder ya no es mucho problema.

    Saludos.
  4. omega2811763

    omega2811763 New Member

    Me Gusta recibidos:
    0
    :cool:Ryo una pregunta como haría para pasar de una configuración como la q dejaste en el web proxy que no me permite usar el access list, que lo necesito para hacer redirecciones, A Configurar thunder como Parent Proxy de Mikrotik. Lo he intentado con los pasos y nada no pasa nada, una ayudita pues, GRACIAS.:cool:
  5. ryohnosuke

    ryohnosuke MikroTik Support Guy Administrador

    Me Gusta recibidos:
    122
    Si lo has configurado tal como está aquí en este guía, entonces debería funcionar, pero como comentas que YA tienes un thunder, seguro tienes esta config en este preciso momento http://www.ryohnosuke.com/foros/index.php?threads/246/, así tienes que borrar la redirección en IP -> Firewall -> pestaña NAT de la config anterior, para seguir con esta guía, o en todo caso modificarla.

    Saludos.
    Última edición: 28 Mar 2014
  6. omega2811763

    omega2811763 New Member

    Me Gusta recibidos:
    0
    Ryo me dices o modificarla, pero eso lo lo veo como ha configurar de nuevo y qué pasaría si me equivoco en algún parámetro me ayudarías en la corección???:confused:
  7. omega2811763

    omega2811763 New Member

    Me Gusta recibidos:
    0
    Ryo ya lo hice no te preocupes, gracias x los consejos, me sirvieron para el web proxy, el cambiar en MANGLE el chain de forward por output, y un truquito que me salió en la parte de ip-firewall-nat-redireccion a thunder-action-to addresses: coloque una ip básica y empezó a funcionar thunder y web proxy a la vez, cómo me dí cuenta, viendo videos cacheados corrían(thunder funciona), bloqueandome páginas denegas en web proxy(trabaja web proxy).
    Ryo gracias y disculpa la incomodidad. Ah y funciona eso del cambio del logo de google.
    GRACIAS :cool:.
  8. ryohnosuke

    ryohnosuke MikroTik Support Guy Administrador

    Me Gusta recibidos:
    122
    En realidad era plan de ver la guía para el proxy paralelo, luego con eso quitar todo lo que aparecía ahí, y luego seguir estas guía xD Igual, si te funcionó, excelente.

    Saludos.
  9. JOtiniano

    JOtiniano New Member

    Me Gusta recibidos:
    0
    Estimado veo que a ti si te a salido ese tema de usar el access list, con el thunder, en realidad a mi aun no me sale use la regla de: Configurar ThunderCache como Parent Proxy de MikroTik y las reglas que pone ahi Ryo:
    /ip address
    add address=192.168.2.1/24 interface=THUNDER

    /ip firewall nat
    add action=dst-nat chain=dstnat comment="Redireccion a Thunder" dst-port=80 in-interface=LAN protocol=tcp to-ports=8000

    Haciendo la segunda regla no logro hacer funcionar el Thunder, coloque otra regla que busque por ahi y logre hacer funcionar el thunder con el Mk, ahora el problema es que no me correo el Acces List.

    Haber si me hechas una mano con las reglas te lo agradeceria bastante Amigo, gracias.
  10. ryohnosuke

    ryohnosuke MikroTik Support Guy Administrador

    Me Gusta recibidos:
    122
    Las reglas tal como están funciona perfectamente, lo más probable es que tengas que configurar adecuadamente tu server thunder.

    Saludos.
  11. JOtiniano

    JOtiniano New Member

    Me Gusta recibidos:
    0
    Si me indicas que eso esta bien entonces dime tu que es lo que tendria que hacer en el CPanel del Thunder, lo que hecho es solo modificar el Puerto y ahora esoty trabajando con el 3128.
    Una Ayudita porfa...
  12. ryohnosuke

    ryohnosuke MikroTik Support Guy Administrador

    Me Gusta recibidos:
    122
    Quizá te funcione si juegas con la opción transparent proxy, pero no estoy seguro.

    Saludos.
  13. joemg6

    joemg6 New Member

    Me Gusta recibidos:
    0
    Si estas usando Thundercache 6 la version free, dentro de sus limitaciones esta que no puede hacer Proxy Parent.
  14. bayron

    bayron Member

    Me Gusta recibidos:
    0
    Hola amigo Ryohnosuke desde Venezuela, amigo quisiera saber como colocarle una ip fija al thunder, sin configurar el servidor dhcp, la interfas en mikrotik es 192.168.2.1 y se llama thunder, pero luego como acceso al thunder? le quiero colocar la direccion ip 192.168.2.2 mas no se como hacerlo sin configurar servidor dhcp, esto porque no quiero que el mikrotik me pida dns, segun entiendo este valor debe ser 127.0.0.1 y no un valor diferente. Gracias amigo
  15. Rejonathan

    Rejonathan New Member

    Me Gusta recibidos:
    1
    Humm si ese es el caso como podría hacerlo funcionar.... Ryo creo que tu eres el indicado en decirnos eso, y sacarnos de la duda
  16. ryohnosuke

    ryohnosuke MikroTik Support Guy Administrador

    Me Gusta recibidos:
    122
    Sorry, al parecer eso también dice el creador en su foro, el thundercache demo no puede ser usado como parent proxy.

    Saludos.
  17. Rejonathan

    Rejonathan New Member

    Me Gusta recibidos:
    1
    Entonces el Demo es el ADS????
  18. ryohnosuke

    ryohnosuke MikroTik Support Guy Administrador

    Me Gusta recibidos:
    122
    Claro, es el demo gratuito...

    Saludos.
  19. bayron

    bayron Member

    Me Gusta recibidos:
    0
    Hola amigos estoy usando el thunder en paralelo con mikrotik, solo quiero saber como colocarle la ip al thunder sin servidor dhcp. Gracias amigos
  20. Rejonathan

    Rejonathan New Member

    Me Gusta recibidos:
    1
    bueno
    si estas usando linus bueno te ayudo
    tienes que loguearte como root
    para eso usas esto
    CODE, HTML o PHP Insertado:
    sudo su -
    despues pones la contraseña
    bueno despues de eso entras a
    CODE, HTML o PHP Insertado:
    cd /etc/network/
    y das con el comando
    CODE, HTML o PHP Insertado:
    nano interfaces
    auto lo
    iface lo inet loopback
    #Se inserta la configuración de las tarjetas de red
    #tajeta interna de coneccion a internet del servidor

    auto eth0
    iface eth0 inet static
    address 192.168.1.2
    netmask 255.255.255.0
    gateway 192.168.1.1
    #segunda tarjeta esta es del servidor para los clientes
    auto eth1
    iface eth1 inet static
    address 192.168.2.1
    netmask 255.255.255.0

    Ahora tu mismo eres...

    ten en cuenta que al momento de quitar el DHCP ya no tendrás las direcciones de resolución de nombres..

Compartir esta página