Balanceo dejo de funcionar

Tema en 'Balanceo de Carga (Load Balance)' iniciado por ZardwiZ, 11 Oct 2017.

Etiquetas:
  1. ZardwiZ

    ZardwiZ New Member

    Me Gusta recibidos:
    0
    Voy con un poco de historia para que me entiendan la situación, a ver si me pueden orientar a encontrar la falla.
    Hace dos años aproximadamente configure en nuestra empresa un Mikrotik RB751G con un balanceo de dos lineas wan. Este mikrotik funciona como controlador y como balanceador (se que no es lo ideal, pero salio funcionando sin problemas).
    Recientemente, decidimos usar una pc para suplantar al mikrotik y luego de configurarlo de la misma manera que estaba el mikrotik, el viernes pasado decidimos sacar un equipo y colocar el otro. Esto no funciono como queríamos y volvimos al Mikrotik.
    Desde ese momento, el balanceo dejo de funcionar. Todo el trafico sale por la WAN A y nada del trafico sale por la WAN B. Si desactivo la interfase de la WAN A, ahi si empieza a funcionar sin problemas el trafico por la WAN B.
    Como hago un backup diario de la configuración, compare linea a linea el código actual con un backup, por si hubiera hecho algún cambio sin darme cuenta, pero ambos script son iguales.
    Con lo que me deja sin respuesta de porque antes andaba el balanceo (por 2 años) y de repente dejo de andar.

    les paso las partes del mangle, del route, y del Nat que es el unico lugar donde se me ocurre que podria estar algo mal

    la interfase que funciona es la ether2 y la que no hace el balanceo es la ether1.
    Ether1: wan con ip fija (ARNET)
    Ether2: wan con ip otorgada por dhcp-client (FIBERTEL)

    Insertar CODE, HTML o PHP:
    /ip route
    add check-gateway=ping distance=1 gateway=181.15.88.241 routing-mark=to_arnet
    add check-gateway=ping comment=Fibertel distance=1 gateway=ether2 \
        routing-mark=to_fibertel
    add check-gateway=ping comment="Puerta de Enlace Fibertel" distance=1 \
        gateway=ether2
    add check-gateway=ping comment="Puerta de Enlace Arnet Dedicado" distance=2 \
        gateway=181.15.88.241
    Insertar CODE, HTML o PHP:
    /ip firewall mangle
    
    add chain=prerouting disabled=yes dst-port=21 in-interface=ether3 protocol=\
        tcp
    add chain=prerouting dst-port=53 in-interface=ether3 protocol=udp
    add chain=prerouting dst-port=80 in-interface=ether3 protocol=tcp
    add chain=prerouting comment=DHCP dst-port=67 in-interface=ether3 protocol=\
        udp
    add chain=prerouting dst-port=68 in-interface=ether3 protocol=udp
    add action=mark-routing chain=prerouting comment="Https:// Por Arnet" \
        content=!*facebook* dst-port=443 new-routing-mark=arnet_conn passthrough=\
        no protocol=tcp
    add action=mark-routing chain=prerouting comment="7002 por Arnet" content=\
        !*facebook* dst-port=7002 new-routing-mark=arnet_conn passthrough=no \
        protocol=tcp
    add action=mark-routing chain=prerouting comment=Gateway new-routing-mark=\
        arnet_conn passthrough=no src-address=172.20.0.1
    add action=mark-routing chain=prerouting comment=\
        "Correo Saliente usa la conexion de Fibertel" dst-port=25 \
        new-routing-mark=fibertel_conn passthrough=no protocol=tcp
    add action=mark-routing chain=prerouting comment=\
        "Correo Entrante usa la conexion de fibertel" dst-port=110 \
        new-routing-mark=fibertel_conn passthrough=no protocol=tcp
    add action=mark-routing chain=prerouting comment=\
        "Sacar siempre por fibertel a los clientes de la siguiente lista" \
        in-interface=ether2 new-routing-mark=to_fibertel passthrough=no \
        src-address=71.5.107.59
    add action=mark-connection chain=prerouting comment=\
        "Marcar conexiones que entran por Arnet" connection-state=new \
        in-interface=ether1 new-connection-mark=arnet_conn
    add action=mark-connection chain=prerouting comment=\
        "Marcar conexiones que entran por Fibertel" connection-state=new \
        in-interface=ether2 new-connection-mark=fibertel_conn
    add action=mark-connection chain=prerouting comment=\
        "Puertos TCP que deben salir solo por fibertel" connection-state=new \
        dst-address-type=!local dst-port=7000,1433 in-interface=ether3 \
        new-connection-mark=fibertel_conn protocol=tcp
    add action=mark-routing chain=output comment="Marcar paquetes que entraron por\
        \_Arnet para salida por la misma conexion" connection-mark=arnet_conn \
        new-routing-mark=to_arnet
    add action=mark-routing chain=output comment="Marcar paquetes que entraron por\
        \_Fibertel para salida por la misma conexion" connection-mark=\
        fibertel_conn new-routing-mark=to_fibertel
    add action=mark-connection chain=prerouting connection-state=new \
        dst-address-type=!local in-interface=ether3 new-connection-mark=\
        fibertel_conn per-connection-classifier=both-addresses:3/0
    add action=mark-connection chain=prerouting connection-state=new \
        dst-address-type=!local in-interface=ether3 new-connection-mark=\
        fibertel_conn per-connection-classifier=both-addresses:3/1
    add action=mark-connection chain=prerouting connection-state=new \
        dst-address-type=!local in-interface=ether3 new-connection-mark=\
        arnet_conn per-connection-classifier=both-addresses:3/2
    add action=mark-routing chain=prerouting comment=\
        "Marcar para ruteo por cada salida (to_arnet)" connection-mark=arnet_conn \
        in-interface=ether3 new-routing-mark=to_arnet
    add action=mark-routing chain=prerouting comment=\
        "Marcar para ruteo por cada salida (to_fibertel)" connection-mark=\
        fibertel_conn in-interface=ether3 new-routing-mark=to_fibertel
    
    Insertar CODE, HTML o PHP:
    /ip firewall nat
    add action=masquerade chain=srcnat comment="Enmascarado Arnet dedicada" \
        out-interface=ether1
    add action=masquerade chain=srcnat comment="Enmascarado Fibertel" \
        out-interface=ether2
     

Compartir esta página