Limitar Facebook y Youtube

Tema en 'Queues' iniciado por arielf, 7 Ago 2017.

  1. arielf

    arielf Member

    Me Gusta recibidos:
    11
    Hola foro tengo , el siguiente esquema

    5 Colas simples, limitando mis clientes, cada cola tiene la siguiente configuracion.
    Tengo en Target los rangos ip de los clientes ( 172.16.10.xx - 172.16.20.xx - 172.16.30.xx, etc)
    En queue type selecciono un tipo de cola ya cargado en queue type que es un PCQ.
    No hago marcado en mangle.
    Bien, ahora queria consultar lo siguiente,
    Puedo limitar el trafico de youtube y fgacebook por ejemplo si un abonado tiene 1 MB que no supere ese trafico 800K al menos necesito hacerlo hasta que me ampliene el ancho de banda.

    Gracias
     
  2. LUIS GARZON

    LUIS GARZON Active Member

    Me Gusta recibidos:
    79
    Puedes limitar el ancho de banda, te puedo pasar las reglas, pero recuerda que si limitas facebook también estás limitando a whatsapp y a instaram ya que usan las mismas direcciones ips. Y si limitas youtube también estarás limitando a google, google play, google maps, gmail, etc, etc...
     
    A arielf le gusta esto.
  3. arielf

    arielf Member

    Me Gusta recibidos:
    11
    gracias,, si puedes pasame las reglas para probar
     
  4. LUIS GARZON

    LUIS GARZON Active Member

    Me Gusta recibidos:
    79
    RECUERDA LEER BIEN LAS REGLAS Y CAMBIAR ETHER1 POR EL NOMBRE DE TU INTERFACE WAN. Si no lo haces la regla dará error de sintaxis.

    Debes agregar las direcciones ips de tus clientes a ip firewall address list con el nombre de lista LIMITAR YOUTUBE/FACEBOOK

    Lo que las reglas hacen es obtener las direcciones ips según reglas del layer y de connten para un grupo específico de direcciones ips.

    Se agregan reglas en
    firewall filter
    firewall mangle
    firewall layer-7
    firwall address-list
    queue tree
    queue types

    Copias las reglas de grupo por grupo para que te percates mejor si hay o no errores en ellas.

    /ip firewall layer7-protocol
    add comment=YOUTUBE name=youtube regexp="^.*(youtube).*\$"
    add comment="VIDEO YOUTUBE" name="GOOGLE VIDEO" regexp="^.*(ytimg.com).*\$"
    add comment="VIDEO YOUTUBE" name="GOOGLE VIDEO-2" regexp="^.*(googlevideo).*\$"
    add comment="GOOGLE PLAY" name="GOOGLE PLAY" regexp="^.*(play.google.com).*\$"
    add comment="GOOGLE PLAY" name="CLIENTE ANDROID" regexp="^.*(android.clients.google.com).*\$"


    /ip firewall filter

    add action=add-dst-to-address-list address-list="servicios google" address-list-timeout=5s chain=forward comment="MARCAR YOUTUBE" disabled=yes layer7-protocol=youtube out-interface=ether1 src-address-list="LIMITAR YOUTUBE/FACEBOOK"

    add action=add-dst-to-address-list address-list="servicios google" address-list-timeout=5s chain=forward disabled=yes layer7-protocol="GOOGLE VIDEO" out-interface=ether1 src-address-list="LIMITAR YOUTUBE/FACEBOOK"

    add action=add-dst-to-address-list address-list="servicios google" address-list-timeout=5s chain=forward disabled=yes layer7-protocol="GOOGLE VIDEO-2" out-interface=ether1 src-address-list="LIMITAR YOUTUBE/FACEBOOK"

    add action=add-dst-to-address-list address-list="servicios google" address-list-timeout=5s chain=forward content=youtube.com disabled=yes out-interface=ether1 src-address-list="LIMITAR YOUTUBE/FACEBOOK"

    add action=add-dst-to-address-list address-list="servicios google" address-list-timeout=5s chain=forward content=www.youtube.com disabled=yes out-interface=ether1 src-address-list="LIMITAR YOUTUBE/FACEBOOK"

    add action=add-dst-to-address-list address-list="servicios google" address-list-timeout=5s chain=forward disabled=yes layer7-protocol="GOOGLE PLAY" out-interface=ether1 src-address-list="LIMITAR YOUTUBE/FACEBOOK"

    add action=add-dst-to-address-list address-list="servicios google" address-list-timeout=5s chain=forward disabled=yes layer7-protocol="CLIENTE ANDROID" out-interface=ether1 src-address-list="LIMITAR YOUTUBE/FACEBOOK"


    /ip firewall mangle
    add action=mark-packet chain=postrouting comment="MACADO SERVICIOS GOOGLE" disabled=no dst-address-list="LIMITAR YOUTUBE/FACEBOOK" new-packet-mark="servicios google" passthrough=no src-address-list="servicios google"

    /queue type
    add kind=pcq name=512K-DOWN pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=512k pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=2000

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=10M name="SERVICIOS GOOGLE" packet-mark="servicios google" parent=global priority=8 queue=512K-DOWN


    /ip firewall address-list add address=216.115.98.0/24 list=IP-FACEBOOK comment="FACEBOOK"
    /ip firewall address-list add address=173.252.91.0/24 list=IP-FACEBOOK comment="FACEBOOK"
    /ip firewall address-list add address=216.58.219.0/24 list=IP-FACEBOOK comment="FACEBOOK"
    /ip firewall address-list add address=204.237.0.0/16 list=IP-FACEBOOK comment="FACEBOOK"
    /ip firewall address-list add address=23.201.0.0/16 list=IP-FACEBOOK comment="FACEBOOK"
    /ip firewall address-list add address=23.74.0.0/16 list=IP-FACEBOOK comment="FACEBOOK"
    /ip firewall address-list add address=157.240.0.0/16 list=IP-FACEBOOK comment="FACEBOOK"
    /ip firewall address-list add address=173.45.161.0/24 list=IP-FACEBOOK comment="FACEBOOK"
    /ip firewall address-list add address=192.185.109.0/24 list=IP-FACEBOOK comment="FACEBOOK"
    /ip firewall address-list add address=69.171.230.0/24 list=IP-FACEBOOK comment="FACEBOOK"
    /ip firewall address-list add address=31.13.60.0-31.13.99.255 list=IP-FACEBOOK comment="FACEBOOK"


    #PUEDES AGREGAR MAS DIRECCIONES IPS EN LA LISTA DE IP-FACEBOOK HACIENDO UN PING A FACEBOOK.COM WWW.FACEBOOK.COM Y M.FACEBOOK.COM Y VERIFICAR SI ESTÁN O NO.

    /ip firewall filter
    add action=add-dst-to-address-list address-list="IP-FACEBOOK" address-list-timeout=5s chain=forward content=fbcdn.net disabled=yes out-interface=ether1 src-address-list="LIMITAR YOUTUBE/FACEBOOK" comment="MARCADO FACEBOOK"

    /ip firewall mangle
    add action=mark-packet chain=postrouting comment="MACADO SERVICIOS FACEBOOK" disabled=no dst-address-list="LIMITAR YOUTUBE/FACEBOOK" new-packet-mark="servicios facebook" passthrough=no src-address-list="IP-FACEBOOK"

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=10M name="SERVICIOS FACEBOOK" packet-mark="servicios facebook" parent=global priority=8 queue=512K-DOWN


    Puedes cambiar el valor de la velocidad de 512K a cualquiera en queue type y allí cambias el valor del rate

    Por último, lo mejor serías que agilices el aumento de ancho de banda de tu internet, ya que vas a limitar los servicios mas usados, los de google y los de facebook, de lo contrario emezarás tu wips con el pie izquierdo.

    SALUDOS
     
  5. arielf

    arielf Member

    Me Gusta recibidos:
    11
    Probando,, soalmente una duda,, porque la regla filter?
    gracias
     
  6. LUIS GARZON

    LUIS GARZON Active Member

    Me Gusta recibidos:
    79
    Resulta que marcar https no es tan sencillo. Entonces para eso mejor se marcar las conexiones salientes, es decir las que pasan por el mikrotik a travez del ethert 1 y salen hacia los clientes. Se discriminan las conexiones por layer y por connten para saber qué direcciones agregar a la lista y cuáles no. De lo contrario tendrías que agregar direcciones de todo youtube, con la regla del layer se evita eso ya que limita todo lo que tenga arriba en la barra de direcciones "youtube". El detalle es que ahí cae google y compañía por usar las mismas ips.
     
    A arielf le gusta esto.
  7. arielf

    arielf Member

    Me Gusta recibidos:
    11
    GRACIAS hoy ya lo deje en funcionamiento con algunos abonados para ver como se comporta.;):D
     
  8. LUIS GARZON

    LUIS GARZON Active Member

    Me Gusta recibidos:
    79
    Vale, saludos
     

Compartir esta página