CONSULTA; como balancear mi red sin hacer load balance

Tema en 'Enlaces y Proyectos Inalámbricos' iniciado por Davey Valenzuela, 23 Nov 2016.

  1. Davey Valenzuela

    Davey Valenzuela Member

    Me Gusta recibidos:
    8
    que tal, aqui de nuevo consultando esperando no molestar a alguien con mayores conocimientos que yo en el tema,
    bueno la idea es que tengo un balanceo hecho de 2 lineas de 15mb y 2 de 8mb, al parecer todo funciona bien pero e notado que se satura un poco a todos mis clientes los tengo con simple queue con rafagas, son 60 aprox. entonces el problema es que tengo la red en cuatro partes las cuales se unen a un enlace que va directo a un RB2011 atravez powerbeam m5, como en este caso tengo cuatro lineas y tengo cuatro partes de mi red, quiero asignarle una linea a cada parte la cual es un pico o un bullet a los cuales a los bullets les cuelgo 20 clientes y a los picos 10 aprox, todos con ips staticas en sus cpes clientes (en modo router) en teoria tengo 4 grupos de clientes y quiero que cada grupo de cliente se conecte solo a la linea que le corresponda y no se haga un balanceo de cargas si no que atravez del mismo enlace cada grupo tenga asignado un ETHER por donde salir, ya que e notado que en grupos aveces no ocupan muchos la red y los pocosque la quieren usar en horas pico se les alentiza, la idea es que si se satura una linea solo me perjudicaria un grupo y no toda plantilla de clientes, ademas con esto arreglaria un poco lo de las fallas de internet que hay seguido en base que cuando se va una linea no me fuciona el balanceo y se quedan todos sin red y asi pienso que seria mismo efecto solo un grupo se quedaria sin red y no todos.

    realmente soy aun nuevo aqui y la verdad me han ayudado mucho, solo necesito un empujoncito, suponiendo que tengo ya configurado los gateways en los ether1,2,3 y 4 y el dhcp server en el ether10 en el RB, que reglas proseguirán para lograr mi cometido, la verdad mis ideas son un poco locas pero bueno no me importa experimentar con tal de dar mejor servicio que mi competencia

    les dejo un leve diagrama de mi red para que sen den una idea mejor, ojala me puedan ayudar
    [​IMG]
     
  2. Victor Ramos

    Victor Ramos Well-Known Member

    Me Gusta recibidos:
    644
    Intenta con esto.... adaptalo a tus necesidades...

    http://www.ryohnosuke.com/foros/index.php?threads/15558/

    Saludos...
     
  3. rafaelgc

    rafaelgc Well-Known Member

    Me Gusta recibidos:
    358
    Lo que quieres hacer es repartir cada línea entre unos usuarios concretos.

    La implementación es muy sencilla. Basta con personalizar las reglas NAT de masquerade que tienes realizadas.

    Para cada línea tienes una regla de masquerade. Añade en cada una el rango ip de origen que quieres que salga por ella y todo resuelto. Por ejemplo, si ahora tienes la regla:

    CODE, HTML o PHP Insertado:
    add action=masquerade chain=srcnat out-interface=WAN1
    Sustituyelo por:

    CODE, HTML o PHP Insertado:
    add action=masquerade chain=srcnat out-interface=WAN1 src-address=192.168.88.90-192.168.88.100
     
    A XxjeanpieroxX le gusta esto.
  4. Davey Valenzuela

    Davey Valenzuela Member

    Me Gusta recibidos:
    8
    buenas respuestas, probare y les comento, les agradezco
     
  5. Davey Valenzuela

    Davey Valenzuela Member

    Me Gusta recibidos:
    8
    bueno por ahorita estoy probando, con mi RB balanceado, le agregue despues estas reglas para cada grupo de clientes que tengo al cual le cree un adress list. a cada grupo

    /ip firewall address-list
    add list=CLIENTE_WAN4 address=(ips de clientes grupo 4)

    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.23.1 scope=255 target-scope=10 routing-mark="clients wan4" comment="clients wan4" disabled=no

    / ip firewall mangle
    add chain=prerouting action=mark-routing new-routing-mark="clients wan4" src-address-list=CLIENTE_WAN4 passthrough=no comment="" disabled=no


    hasta ahorita primeras pruebas satisfactorias, seguiré experimentando haber si logro hacerlo pero sin balanceo de carga funcionando. si alguien tiene alguna otra idea, critica o correcion recibida, se lo agradecere
     
  6. rafaelgc

    rafaelgc Well-Known Member

    Me Gusta recibidos:
    358
    Ese abordaje también es correcto, aunque requiere mangle y mayor uso de cpu.
     
  7. Davey Valenzuela

    Davey Valenzuela Member

    Me Gusta recibidos:
    8
    las reglas que me pusiste anteriormente, se pueden poner despues del balanceo o funcionan sin balanceo?
     
  8. rafaelgc

    rafaelgc Well-Known Member

    Me Gusta recibidos:
    358
    E
    Ese nat funcionará sin balanceo.
     

Compartir esta página