ayuda, crear regla para facebook l7

Tema en 'Firewall' iniciado por PUPIO_11, 16 Jul 2016.

  1. PUPIO_11

    PUPIO_11 Member

    Me Gusta recibidos:
    10
    Hola, recurro a ustedes nuevamente porque ya he intentado hacerlo por mi cuenta pero la verdad me falta muchisimo que aprender, quiero marcar el facebook para darle prioridad encima de las descargas, p2p, pero menor prioridad que la navegación y quizas los videos de youtube, todo lo anterior ya esta marcado y priorizado, solo no hallo la forma de hacerlo al facebook, hablo de los videos y las imagenes. Mediante el torch obtuve que las ip que utiliza facebook aqui en MÉXICO son:
    Insertar CODE, HTML o PHP:
    31.13.73.14
    31.13.73.36
    31.13.73.7
    31.13.73.12
    31.13.73.2
    31.13.73.1
    son las que más consumo me dan al momento de reproducir un video o mirar una imagen, mediante un converso de host me indica que los dominios a los que pertenecen esos ip son:
    Insertar CODE, HTML o PHP:
    xx-fbcdn-shv-01-mia1.fbcdn.net
    edge-video-shv-01-mia1.fbcdn.net
    edge-star-mini-shv-01-mia1.facebook.com
    xx-fbcdn-shv-01-mia1.fbcdn.net
    edge-liverail-shv-01-mia1.facebook.com
    edge-atlas-shv-01-mia1.facebook.com
    Creo el marcado lo hago bien (creo porq no estoy seguro) pero al momento de priorizar en quee tree no me marca trafico, o quizas no lo adapto al qos que ya tengo operando, lo marco de la siguiente forma:

    Insertar CODE, HTML o PHP:
    /ip firewall mangle
    add action=mark-connection chain=prerouting dst-address-list="FACEBOOK 2" \
        new-connection-mark=facebook
    add action=mark-packet chain=prerouting connection-mark=facebook \
        new-packet-mark=facebook passthrough=no
    y no se que regex poner en layer 7, ahi se me dificulta mucho, y al momento de agregarlo a mi qos tambien, mi qos es el siguiente:

    Insertar CODE, HTML o PHP:
    /queue tree
    add limit-at=1M max-limit=2M name=upload parent=WAN priority=1
    add limit-at=32M max-limit=37M name=Recepcion parent=CLIENTES priority=1
    add name=Dns_in packet-mark=dns_pkt parent=upload priority=1 queue=default
    add max-limit=100k name=Icmp_in packet-mark=icmp_pkt parent=upload priority=1 \
        queue=default
    add max-limit=1M name=Youtube_in packet-mark=youtube_pkt parent=upload \
        priority=3 queue=default
    add limit-at=1k max-limit=2k name=P2p_in packet-mark=p2p_pkt parent=upload \
        queue=default
    add max-limit=1564M name="Http Up" packet-mark=http_up_pkt parent=upload \
        priority=2 queue=default
    add limit-at=96k max-limit=256k name=Otras packet-mark=otras_pkt parent=upload \
        queue=default
    add limit-at=256k max-limit=512k name=Otras_UDP packet-mark=otras_udp_pkt \parent=upload queue=default
    add max-limit=6M name="Http down small" packet-mark=http_down_pkt parent=\
        Recepcion priority=1 queue=default
    add max-limit=3M name="Http down medium" packet-mark=http_down_medium_pkt \
        parent=Recepcion priority=2 queue=default
    add max-limit=10M name="Http down big" packet-mark=http_down_big_pkt parent=\
        Recepcion queue=default
    add max-limit=2M name="Otras udp" packet-mark=otras_udp_all_pkt parent=\
        Recepcion queue=default
    add max-limit=2556k name="Otras small" packet-mark=otras_small_pkt parent=\
        Recepcion priority=4 queue=default
    add max-limit=2M name="Otras large" packet-mark=otras_large_pkt parent=\
        Recepcion queue=default
    add max-limit=20M name="Youtube down" packet-mark=youtube_down_pkt parent=\
        Recepcion priority=3 queue=default
    add name=facebook packet-mark=facebook parent=Recepcion piority=2 queue=default
    queue=default
    Si pudieran orientarme se lo agradeceré, muchas gracias anticipadas
     
  2. Shadow

    Shadow New Member

    Me Gusta recibidos:
    0
    Aun nadie ha solucionado este problema? estoy con el mismo problema.
     
  3. LUIS GARZON

    LUIS GARZON Active Member

    Me Gusta recibidos:
    79
    Una buena idea es hacer un pin desde tu pc a facebook y la direccion ip que te de la bloqueas en firewall filter con una regla simple, dst address, y action drop.
    Luego hacer otro ping, pero como la direccion ip a la que le ibas a hacer ping está bloqueada, se redireccionará a otro servidor, y haces lo mismo con esta ip en firewall filter, luego a otra y a otra ip hasta que ya no tengas respuesta en el ping, de esta manera obtendras todas las direccion ip para cierto dominio, en este caso Facebook. Y entonces tendrás las direcciones Ip a marcar. Otra cosa, las imagenes. videos y demás que aparecen en facebook por lo general son ajena a ésta página por ende no podrás marcarlas con el ping anteriormente mencionado.
     
  4. Joso

    Joso Member

    Me Gusta recibidos:
    5

    Yo tengo bloqueo en L7 para facebook y no he tenido problemas.

    permiteme unas horas y la coloco aqui.
     
  5. PUPIO_11

    PUPIO_11 Member

    Me Gusta recibidos:
    10
    Hola amigo, postearas las reglas? es Facebook para mexico? saludos
     
  6. Joso

    Joso Member

    Me Gusta recibidos:
    5
    Sorry, no me acordaba, aqui les dejo un bloqueo por capa 7 para facebook:

    /ip firewall layer7-protocol
    add name="Block Face" regexp="^.+(facebook.com).*\$"

    /ip firewall filter
    add action=drop chain=forward comment="block face" dst-port=443 in-interface=LAN1 layer7-protocol="Block Face" protocol=tcp src-address=(Aqui va tu LAN o la ip que deseas bloquear acceso)
    add action=drop chain=forward dst-port=80 in-interface=LAN1 layer7-protocol="Block Face" protocol=tcp src-address=(Aqui va tu LAN o la ip que deseas bloquear acceso)

    con esto estamos bloqueando completamente el facebook, les dejo una captura para que vean que no hay acceso:

    [​IMG]


    Agradecer no cuesta ;-)
     
  7. lukpo02

    lukpo02 Member

    Me Gusta recibidos:
    17
    Te consulto, lo probaste de esta manera para APPS de Android u IOS???
     

Compartir esta página