Ayuda con Limitacion de ancho de banda con PCQ+QUEUE TREE

Tema en 'MikroTik RouterOS (General)' iniciado por janddo, 20 Feb 2012.

  1. janddo

    janddo Active Member

    Me Gusta recibidos:
    18
    Hola a todos, Nuevamente acudo a uds. para me me brinden su ayuda; Les comento que estoy usando la limitacion de ancho de banda con PCQ Y QUUEUE TREE siguiendo esta guia hecha por nuestro amigo soul4ever, tambien tengo implementado el THUNDER CACHE segun esta guia, el problema que tengo es cuando activo el redireccionamineto hacia Thunder, el PCQ de la velocidad de subida ya no controla, a todos los tipos de clientes (Basico, Medio, Premiun, Bold )les da el ancho de banda maximo de subida de mi red, tengo 3M/512k pero en horas de trabajo (10am a 03pm)solo llega a 2103k de Downloady 375k Upload Aproximadamente; solo conectado una pc (no los clientes).

    QUEUE TYPE
    CODE, HTML o PHP Insertado:
    add kind=pcq name=PCQ_Down_Basico pcq-burst-rate=0 pcq-burst-threshold=0 \
        pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 \
        pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=128k pcq-src-address-mask=\
        32 pcq-src-address6-mask=64 pcq-total-limit=2000
    add kind=pcq name=PCQ_Up_Basico pcq-burst-rate=0 pcq-burst-threshold=0 \
        pcq-burst-time=10s pcq-classifier=src-address pcq-dst-address-mask=32 \
        pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=64k pcq-src-address-mask=\
        32 pcq-src-address6-mask=64 pcq-total-limit=2000
    add kind=pcq name=PCQ_Down_Gold pcq-burst-rate=0 pcq-burst-threshold=0 \
        pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 \
        pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=1M pcq-src-address-mask=32 \
        pcq-src-address6-mask=64 pcq-total-limit=2000
    add kind=pcq name=PCQ_Up_Gold pcq-burst-rate=0 pcq-burst-threshold=0 \
        pcq-burst-time=10s pcq-classifier=src-address pcq-dst-address-mask=32 \
        pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=256k pcq-src-address-mask=\
        32 pcq-src-address6-mask=64 pcq-total-limit=2000
    add kind=pcq name=PCQ_Down_Premiun pcq-burst-rate=0 pcq-burst-threshold=0 \
        pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 \
        pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=512k pcq-src-address-mask=\
        32 pcq-src-address6-mask=64 pcq-total-limit=2000
    add kind=pcq name=PCQ_Up_Premiun pcq-burst-rate=0 pcq-burst-threshold=0 \
        pcq-burst-time=10s pcq-classifier=src-address pcq-dst-address-mask=32 \
        pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=100k pcq-src-address-mask=\
        32 pcq-src-address6-mask=64 pcq-total-limit=2000
    add kind=pcq name=PCQ_Down_Medio pcq-burst-rate=0 pcq-burst-threshold=0 \
        pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 \
        pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=256k pcq-src-address-mask=\
        32 pcq-src-address6-mask=64 pcq-total-limit=2000
    add kind=pcq name=PCQ_Up_Medio pcq-burst-rate=0 pcq-burst-threshold=0 \
        pcq-burst-time=10s pcq-classifier=src-address pcq-dst-address-mask=32 \
        pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=90k pcq-src-address-mask=\
        32 pcq-src-address6-mask=64 pcq-total-limit=2000
    add kind=red name=Macheteo red-avg-packet=1000 red-burst=1601 red-limit=5764 \
        red-max-threshold=2882 red-min-threshold=961
    add kind=red name=Otros red-avg-packet=100 red-burst=3 red-limit=11 \
        red-max-threshold=5 red-min-threshold=2
    
    
    [​IMG]

    NAT
    CODE, HTML o PHP Insertado:
    /ip firewall nat
    add action=masquerade chain=srcnat comment="ENMASCARADO DE RED" disabled=no \
        out-interface=ether1_WAN
    add action=dst-nat chain=dstnat comment="Redireccion a Thunder" disabled=no \
        dst-port=80 in-interface=ether2_LAN protocol=tcp to-addresses=20.0.0.10 \
        to-ports=8080
    
    MANGLE

    CODE, HTML o PHP Insertado:
    /ip firewall mangle
    add action=mark-packet chain=prerouting comment="ICMP ether2_LAN" disabled=no \
        in-interface=ether2_LAN new-packet-mark=icmp_in passthrough=no protocol=\
        icmp
    add action=mark-packet chain=postrouting disabled=no new-packet-mark=icmp_out \
        out-interface=ether2_LAN passthrough=no protocol=icmp
    add action=mark-packet chain=prerouting comment="ICMP WAN" disabled=no \
        in-interface=ether1_WAN new-packet-mark=icmp_in2 passthrough=no protocol=\
        icmp
    add action=mark-packet chain=postrouting disabled=no new-packet-mark=\
        icmp_out2 out-interface=ether1_WAN passthrough=no protocol=icmp
    add action=mark-packet chain=prerouting comment=DNS disabled=no dst-port=53 \
        in-interface=ether2_LAN new-packet-mark=dns_in passthrough=no protocol=\
        udp
    add action=mark-packet chain=prerouting disabled=no dst-port=53 in-interface=\
        ether2_LAN new-packet-mark=dns_in passthrough=no protocol=tcp
    add action=mark-packet chain=forward comment="FULL CACHE" disabled=no dscp=18 \
        new-packet-mark=fullcache passthrough=no
    add action=mark-connection chain=prerouting comment="YouTube connection" \
        content=youtube disabled=no dst-address=74.125.0.0/16 in-interface=\
        ether2_LAN new-connection-mark=youtube_cnx passthrough=yes
    add action=mark-packet chain=prerouting connection-mark=youtube_cnx disabled=\
        no new-packet-mark=youtube_pkt passthrough=no
    add action=mark-packet chain=prerouting disabled=no dst-address=\
        208.117.224.0/19 in-interface=ether2_LAN new-packet-mark=youtube_pkt \
        passthrough=no
    add action=mark-packet chain=prerouting comment="Google Talk" disabled=no \
        dst-port=5222 in-interface=ether2_LAN new-packet-mark=google_pkt \
        passthrough=no protocol=tcp
    add action=mark-packet chain=prerouting comment=Gamezer disabled=no dst-port=\
        843,9000-10000 in-interface=ether2_LAN new-packet-mark=gamezer_pkt \
        passthrough=no protocol=tcp
    add action=mark-packet chain=prerouting comment=Http disabled=no dst-port=80 \
        in-interface=ether2_LAN new-packet-mark=http_up_pkt passthrough=no \
        protocol=tcp
    add action=mark-packet chain=prerouting comment=Https disabled=no dst-port=\
        443 in-interface=ether2_LAN new-packet-mark=https_pkt passthrough=no \
        protocol=tcp
    add action=mark-packet chain=prerouting comment=MSN disabled=no dst-port=1863 \
        in-interface=ether2_LAN new-packet-mark=msn_pkt passthrough=no protocol=\
        tcp
    add action=mark-packet chain=prerouting comment=Telnet disabled=no dst-port=\
        23 in-interface=ether2_LAN new-packet-mark=telnet_pkt passthrough=no \
        protocol=tcp
    add action=mark-packet chain=prerouting comment=SSH disabled=no dst-port=22 \
        in-interface=ether2_LAN new-packet-mark=ssh_pkt passthrough=no protocol=\
        tcp
    add action=mark-packet chain=prerouting comment=FTP disabled=no dst-port=21 \
        in-interface=ether2_LAN new-packet-mark=ftp_pkt passthrough=no protocol=\
        tcp
    add action=mark-packet chain=prerouting comment=WinBox disabled=no dst-port=\
        8291,8292,8293 in-interface=ether2_LAN new-packet-mark=winbox_pkt \
        passthrough=no protocol=tcp
    add action=mark-packet chain=prerouting disabled=no dst-port=20561 \
        in-interface=ether2_LAN new-packet-mark=winbox_pkt passthrough=no \
        protocol=udp
    add action=mark-packet chain=prerouting comment=WoW disabled=no dst-port=\
        3724,6112,6119,6881-6999,8085 in-interface=ether2_LAN new-packet-mark=wow \
        passthrough=no protocol=tcp
    add action=mark-packet chain=prerouting disabled=no dst-port=\
        3724,6112,6119,6881-6999,8085 in-interface=ether2_LAN new-packet-mark=wow \
        passthrough=no protocol=udp
    add action=mark-packet chain=prerouting comment=TeamWeaver disabled=no \
        dst-port=5938 in-interface=ether2_LAN new-packet-mark=teamviewer \
        passthrough=no protocol=tcp
    add action=mark-connection chain=prerouting comment=P2P disabled=no \
        in-interface=ether2_LAN new-connection-mark=p2p_conex p2p=all-p2p \
        passthrough=yes
    add action=mark-packet chain=prerouting connection-mark=p2p_conex disabled=no \
        new-packet-mark=p2p_in passthrough=no
    add action=mark-packet chain=prerouting comment=Otros connection-limit=1,32 \
        disabled=no in-interface=ether2_LAN new-packet-mark=otros_pkt \
        passthrough=no protocol=tcp
    add action=mark-connection chain=forward comment="Clientes basicos" disabled=\
        no new-connection-mark=clientes_basico_conex passthrough=yes \
        src-address-list=BASICO
    add action=mark-packet chain=forward connection-mark=clientes_basico_conex \
        disabled=no new-packet-mark=basicos_packet passthrough=no
    add action=mark-connection chain=forward comment="Cliente Medio" disabled=no \
        new-connection-mark=cliente_medio_conex passthrough=yes src-address-list=\
        MEDIO
    add action=mark-packet chain=forward connection-mark=cliente_medio_conex \
        disabled=no new-packet-mark=medio_packet passthrough=no
    add action=mark-connection chain=forward comment="Clientes Premiun" disabled=\
        no new-connection-mark=clientes_premiun_conex passthrough=yes \
        src-address-list=PREMIUN
    add action=mark-packet chain=forward connection-mark=clientes_premiun_conex \
        disabled=no new-packet-mark=premiun_packet passthrough=no
    add action=mark-connection chain=forward comment="Clientes Gold" disabled=no \
        new-connection-mark=clientes_gold_conex passthrough=yes src-address-list=\
        GOLD
    add action=mark-packet chain=forward connection-mark=clientes_gold_conex \
        disabled=no new-packet-mark=gold_packet passthrough=no
    
    [​IMG]
    [​IMG]
    QUEUE TREE
    CODE, HTML o PHP Insertado:
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=0 name=Total_Download packet-mark="" parent=ether2_LAN priority=1
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=0 name=Total_Upload packet-mark="" parent=ether1_WAN priority=1
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=0 name=Down_Basico packet-mark=basicos_packet parent=\
        Total_Download priority=1 queue=PCQ_Down_Basico
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=0 name=UP_Basico packet-mark=basicos_packet parent=Total_Upload \
        priority=8 queue=PCQ_Up_Basico
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=0 name=Down_Gold packet-mark=gold_packet parent=Total_Download \
        priority=1 queue=PCQ_Down_Gold
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=0 name=UP_Gold packet-mark=gold_packet parent=Total_Upload \
        priority=1 queue=PCQ_Up_Gold
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=512k name=Servicios packet-mark="" parent=global-in priority=1
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=461k name=Dns_in packet-mark=dns_in parent=Servicios priority=1 \
        queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=50k \
        max-limit=461k name=Msn_in packet-mark=msn_pkt parent=Servicios priority=2 \
        queue=Macheteo
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=120k \
        max-limit=1M name=Youtube_in packet-mark=youtube_pkt parent=Servicios \
        priority=8 queue=Macheteo
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=64k \
        max-limit=461k name=TeamViewer packet-mark=teamviewer parent=Servicios \
        priority=8 queue=Macheteo
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=128k \
        max-limit=461k name=Https_Up packet-mark=https_pkt parent=Servicios \
        priority=1 queue=Macheteo
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=13k name=WoW packet-mark=wow parent=Servicios priority=8 queue=\
        Macheteo
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=0 name="ICMP in" packet-mark=icmp_in parent=Servicios priority=1 \
        queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=0 name="Servicios 2" packet-mark="" parent=global-out priority=1
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1k \
        max-limit=1k name=Otros packet-mark=otros_pkt parent=Servicios priority=8 \
        queue=Otros
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=461k name=SSH packet-mark=ssh_pkt parent=Servicios priority=1 \
        queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=20k \
        max-limit=461k name=FTP packet-mark=ftp_pkt parent=Servicios priority=7 \
        queue=Macheteo
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=461k name=Telnet packet-mark=telnet_pkt parent=Servicios \
        priority=7 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1k \
        max-limit=461k name=Talk packet-mark=google_pkt parent=Servicios priority=8 \
        queue=Macheteo
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1k \
        max-limit=128k name=Gamezer packet-mark=gamezer_pkt parent=Servicios \
        priority=8 queue=Macheteo
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=0 name=Dns_out packet-mark=dns_out parent="Servicios 2" priority=\
        1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=0 name=ICMP_in2 packet-mark=icmp_in2 parent=Servicios priority=1 \
        queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=0 name=ICMP_out2 packet-mark=icmp_out2 parent="Servicios 2" \
        priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1k \
        max-limit=1k name=P2P packet-mark=p2p_in parent=Servicios priority=8 queue=\
        Macheteo
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=0 name="ICMP out" packet-mark=icmp_out parent="Servicios 2" \
        priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=3M name=fullcache packet-mark=fullcache parent=global-out \
        priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=0 name=Down_Medio packet-mark=medio_packet parent=Total_Download \
        priority=1 queue=PCQ_Down_Medio
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=0 name=Up_Medio packet-mark=medio_packet parent=Total_Upload \
        priority=8 queue=PCQ_Up_Medio
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=0 name=Down_Premiun packet-mark=premiun_packet parent=\
        Total_Download priority=1 queue=PCQ_Down_Premiun
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
        max-limit=0 name=Up_Premiun packet-mark=premiun_packet parent=Total_Upload \
        priority=2 queue=PCQ_Up_Premiun
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=160k \
        max-limit=461k name="Http Up" packet-mark=http_up_pkt parent="Servicios 2" \
        priority=1 queue=Machete
    
    [​IMG]

    Eso es lo que estoy usando..Por favor espero sus pronta ayuda y comentarios...
    Última edición por un moderador: 27 Mar 2014
  2. janddo

    janddo Active Member

    Me Gusta recibidos:
    18
    Van 15 visitas... aunque se sigan que no saben... yo lo entenderé...
  3. ryohnosuke

    ryohnosuke MikroTik Support Guy Administrador

    Me Gusta recibidos:
    39
    Ciertamente estás preguntando en el lado equivocado, ya lo moví a MikroTik RouterOS, a ver qué dicen.

    Saludos.
  4. jorge1985

    jorge1985 Member

    Me Gusta recibidos:
    0
    hola amigo yo tengo algo parecido con hice con el manual de soul4ever espero t ayude en algo, tngo 3m/768kbps, saludos
    [​IMG]
    ahy esta funcionando si hace full cache,todo bien.
    Última edición por un moderador: 27 Mar 2014
  5. janddo

    janddo Active Member

    Me Gusta recibidos:
    18
    En mi caso si hace full cache... el detalle esta en que al tipo de cliente basico en la subida solo le doy 64k, al momento de hacer el test de velocidad me marca como si estubiera dando todo el ancho de bada de subida a ese tipo de cliente y cuando desactivo el redireccionamiento a thunder me marca bien... ayuda porfavor... se hace llamado a todos los expertos en la rama si no es pedir mucho... gracias...
  6. jjagredar

    jjagredar New Member

    Me Gusta recibidos:
    0
    Janndo, yo tambien tuve ese problema, lo que debes hacer es marcar el global in y global out para que todas las interfaces de entrada y salida se rijan por esta regla en el queue tree...

    Eso es debido a que el manual-guia de janis megis esta elaborada tomando en cuenta 01 wan y 01 lan, pero en nuestro caso como el de muchos, tenemos wan, lan, hotspot, thunder en distintas interfaces las cuales son tanto de bajada como de subida, entonces lo que se debe hacer es englobar las intefaces de entrada y salida para que se rijas por esta regla en quee tree, y no crear una regla para cada inferface como algunos han escrito por alli, espero te sea de provecho y saludos desde venezuela........

Compartir esta página