Export de Reglas [ LOAD BALANCE PCC + PROXY CACHE + SIMPLE QUEUE + HOTSPOT ]

Tema en 'Discusión General' iniciado por wifixvan, 12 Feb 2012.

  1. wifixvan

    wifixvan New Member

    Me Gusta recibidos:
    0
    BALANCEO PCC 2 LINEAS :

    Buen dia a todos, en esta primera oportunidad que tengo quiero hacer un export de la configuracion de mi Server PC Routeros, valga la redundancia es el mismo que hace el balanceo de carga de 2 conexiones de la cuales una de ellas tiene peso doble que la otra, ademas de ser un tipo de balanceo Pcc mixto. tambien controla el ancho de banda por Simple Queues, Full Cache, Dhcp Server, Hotspot añadido para bloquear a los usuario morosos.

    Detalles de la Estructura del Server:
    ether4 : Red Local, Lan, Ether donde los clientes se conectan
    pppoe-out1 : interfaz virtual que hace el marcado pppoe a la vez es la que se balancea con ether2 --> ip: no es necesario
    ether2 : segunda interfaz que se balancea --> ip : 192.10.36.2

    Nat :

    CODE, HTML o PHP Insertado:
    add action=masquerade chain=srcnat comment=Masquerade disabled=no out-interface=pppoe-out1
    add action=masquerade chain=srcnat comment=Masquerade disabled=no out-interface=ether2
     
    Mangle :

    CODE, HTML o PHP Insertado:
    /ip firewall mangle
    add action=accept chain=prerouting comment="trafik clients" disabled=no dst-address-list=clients in-interface=ether4
    add action=accept chain=output disabled=no dst-address-list=clients
    add action=mark-connection chain=prerouting comment="trafik dari isp1" connection-mark=no-mark disabled=no in-interface=pppoe-out1 new-connection-mark=\
        con-from-isp1 passthrough=yes
    add action=mark-connection chain=prerouting comment="trafik dari isp2" connection-mark=no-mark disabled=no in-interface=ether2 new-connection-mark=\
        con-from-isp2 passthrough=yes
    add action=mark-connection chain=output disabled=no dst-address=200.48.225.130 dst-port=53 new-connection-mark=dns passthrough=yes protocol=udp
    add action=mark-connection chain=output disabled=no dst-address=200.48.225.146 dst-port=53 new-connection-mark=dns passthrough=yes protocol=udp
    add action=mark-routing chain=output connection-mark=dns disabled=no new-routing-mark=route-to-isp1 passthrough=no
    add action=jump chain=prerouting comment="lompat ke client-lb" connection-mark=no-mark disabled=no in-interface=ether4 jump-target=client-lb
    add action=jump chain=output comment="lompat ke lb-proxy" connection-mark=no-mark disabled=no jump-target=lb-proxy out-interface=!ether4
    add action=mark-connection chain=client-lb comment="awal loadbalancing klien" disabled=no dst-address-type=!local new-connection-mark=to-isp1 passthrough=yes \
        per-connection-classifier=both-addresses:3/0
    add action=mark-connection chain=client-lb disabled=no dst-address-type=!local new-connection-mark=to-isp2 passthrough=yes per-connection-classifier=\
        both-addresses:3/1
    add action=mark-connection chain=client-lb disabled=no dst-address-type=!local new-connection-mark=to-isp2 passthrough=yes per-connection-classifier=\
        both-addresses:3/2
    add action=return chain=client-lb comment="akhir dari loadbalancing" disabled=no
    add action=mark-connection chain=lb-proxy comment="awal load balancing proxy" disabled=no dst-address-type=!local new-connection-mark=con-from-isp1 \
        passthrough=yes per-connection-classifier=both-addresses:3/0
    add action=mark-connection chain=lb-proxy disabled=no dst-address-type=!local new-connection-mark=con-from-isp2 passthrough=yes per-connection-classifier=\
        both-addresses:3/1
    add action=mark-connection chain=lb-proxy disabled=no dst-address-type=!local new-connection-mark=con-from-isp2 passthrough=yes per-connection-classifier=\
        both-addresses:3/2
    add action=return chain=lb-proxy comment="akhir dari loadbalancing" disabled=no
    add action=jump chain=prerouting comment="marking route client" connection-mark=!no-mark disabled=no in-interface=ether4 jump-target=route-client
    add action=mark-routing chain=route-client connection-mark=to-isp1 disabled=no new-routing-mark=route-to-isp1 passthrough=no
    add action=mark-routing chain=route-client connection-mark=to-isp2 disabled=no new-routing-mark=route-to-isp2 passthrough=no
    add action=mark-routing chain=route-client connection-mark=con-from-isp1 disabled=no new-routing-mark=route-to-isp1 passthrough=no
    add action=mark-routing chain=route-client connection-mark=con-from-isp2 disabled=no new-routing-mark=route-to-isp2 passthrough=no
    add action=return chain=route-client disabled=no
    add action=mark-routing chain=output comment="marking route proxy" connection-mark=con-from-isp1 disabled=no new-routing-mark=route-to-isp1 out-interface=\
        !ether4 passthrough=no
    
    ROUTE:

    CODE, HTML o PHP Insertado:
    /ip route
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=route-to-isp1 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=route-to-isp1 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.10.36.1 routing-mark=route-to-isp2 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=192.10.36.1 routing-mark=route-to-isp2 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=192.10.36.1 scope=30 target-scope=10
    
    Con esas lineas añadidas en las reglas del balanceo PCC haremos que el Proxy Cache pase desapercibido. Aqui el Export de Proxy Cache.

    PROXY :

    CODE, HTML o PHP Insertado:
    /ip proxy
    set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 cache-on-disk=yes enabled=yes max-cache-size=57671680KiB max-client-connections=600 \
        max-fresh-time=3d max-server-connections=600 parent-proxy=0.0.0.0 parent-proxy-port=0 port=5128 serialize-connections=no src-address=0.0.0.0
    
    NAT :

    CODE, HTML o PHP Insertado:
    add action=redirect chain=dstnat comment="Redireccion Proxy Cache" disabled=no dst-port=80 protocol=tcp to-ports=5128
    
    MANGLE FULL CACHE :

    CODE, HTML o PHP Insertado:
    add action=mark-packet chain=postrouting comment="Cache webproxy" disabled=no dscp=4 new-packet-mark=cache_pkt passthrough=no
    
    QUEUE TREE FULL CACHE :

    CODE, HTML o PHP Insertado:
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=5M name="Cache full" packet-mark=cache_pkt parent=global-out priority=1 queue=default
    
    Adecuando esta configuracion a la necesidad de cada uno solo tendrian que editar las reglas, y asi evitar preguntas tales como... pcc no corre con hotspot? proxy cache mikrotik deja de funcionar con hotspot? y cosas asi.. Suerte!
    Última edición: 13 Feb 2012
  2. Anthony

    Anthony New Member

    Me Gusta recibidos:
    0
    Hola wifixvan, mis saludos; tengo una duda sobre la parte del ROUTE, a qué se debe que a la interface pppoe-out1 le pones distancia 1 y 2, lo mismo a la segunda línea, distancia 1 y 2?; cuando a la interface pppoe-out1 solo le corresponde la distancia 1 y a la segunda línea distancia 2?.
    Última edición por un moderador: 27 Mar 2014
  3. lepumin

    lepumin Active Member

    Me Gusta recibidos:
    12
    Interesante aporte.
    Aunque algo más simple en el caso de tener balanceo PCC y webproxy es usar la cadena postrouting para cada una de las interfaces Wan para luego hacer el salto hacia el balance que sería único. Con esto reducimos el número de reglas, podemos usar múltiples ether Lan y la lectura es más simple.
    Faltó añadir el estado de la conexión igual new para evitar balancear 'n' veces y obtener lo mismo.

    Esto respecto a mangle.
    Saludos.
  4. danteviera

    danteviera New Member

    Me Gusta recibidos:
    0
    yo lo tengo asi pero cuando llegas a tener muchos clentes por simple queue se pone un lento y hasta ahora no encuentro la forma de mejorarlo T_T
  5. carlosdark6

    carlosdark6 New Member

    Me Gusta recibidos:
    1

    si es cierto con el simple queue se pone lento recontra lento asi tengas pocos clientes en mi caso hasta cuando solo conecto una maquina bueno no me funciono y no lo volvi a usar
  6. esleyter2010

    esleyter2010 New Member

    Me Gusta recibidos:
    0
    Con la V6 de Mikrotik funciona excelente el simple queue.... ya que atiende todos a la vez y no uno a la vez de forma jerárquica, como en las versiones ante
  7. reggaealex

    reggaealex New Member

    Me Gusta recibidos:
    0
    yo tengo mas de 100 clientes con simple queue y hasta ahorita no he tenido problemas de lentitud
  8. facubertran

    facubertran New Member

    Me Gusta recibidos:
    0
    Hola, hice el balance como esta ahi, pero cuando hago nat directamento no me direcciona al proxy. El proxy esta en una interface distinta a la lan. Esta es la regla de nat que tengo.

    add action=dst-nat chain=dstnat comment=HAARP disabled=yes dst-port=80 \
    in-interface=bridge-4-5 protocol=tcp to-addresses=192.168.3.252 to-ports=\
    3128

    Cual podria ser el problema?

    Gracias.
  9. astrosendero

    astrosendero New Member

    Me Gusta recibidos:
    0
    Hola a todos:

    Tengo un Routerboard configurado en modo hotspot y balanceando 3 conexiones de internet (las WAN estan en Ether1, Ether2 y Ether3)
    El Hotspot esta corriendo en Ether5. Toda la navegacion funciona http y los portales de bancos (https) skype, whattap....

    Pero las maquinas que tienen outlook configurado, sus mails no salen ni entran, debo tener algun bloqueo pero no he podido echar a volar esta parte para que outlook funcione. ¿Me pueden ayudar?


    Mi conf:

    / ip address
    add address=172.16.1.1/24 network=172.16.1.0 broadcast=172.16.1.255 interface=ether5
    add address=10.10.1.2/24 network=10.10.1.0 broadcast=10.10.1.255 interface=ether1
    add address=10.10.2.2/24 network=10.10.2.0 broadcast=10.10.2.255 interface=ether2
    add address=10.10.3.2/24 network=10.10.3.0 broadcast=10.10.3.255 interface=ether3


    / ip firewall mangle
    add chain=prerouting in-interface=ether1 connection-mark=no-mark action=mark-connection new-connection-mark=ISP1_conn


    add chain=prerouting in-interface=ether2 connection-mark=no-mark action=mark-connection new-connection-mark=ISP2_conn


    add chain=prerouting in-interface=ether3 connection-mark=no-mark action=mark-connection new-connection-mark=ISP3_conn




    add chain=prerouting in-interface=ether5 connection-mark=no-mark hotspot=auth dst-address-type=!local per-connection-classifier=both-addresses:3/0 action=mark-connection new-connection-mark=ISP1_conn


    add chain=prerouting in-interface=ether5 connection-mark=no-mark hotspot=auth dst-address-type=!local per-connection-classifier=both-addresses:3/1 action=mark-connection new-connection-mark=ISP2_conn


    add chain=prerouting in-interface=ether5 connection-mark=no-mark hotspot=auth dst-address-type=!local per-connection-classifier=both-addresses:3/2 action=mark-connection new-connection-mark=ISP3_conn


    add chain=prerouting connection-mark=ISP1_conn in-interface=ether5 action=mark-routing new-routing-mark=to_ISP1


    add chain=prerouting connection-mark=ISP2_conn in-interface=ether5 action=mark-routing new-routing-mark=to_ISP2


    add chain=prerouting connection-mark=ISP2_conn in-interface=ether5 action=mark-routing new-routing-mark=to_ISP3


    add chain=output connection-mark=ISP1_conn action=mark-routing new-routing-mark=to_ISP1

    add chain=output connection-mark=ISP2_conn action=mark-routing new-routing-mark=to_ISP2


    add chain=output connection-mark=ISP2_conn action=mark-routing new-routing-mark=to_ISP3


    / ip route
    add dst-address=0.0.0.0/0 gateway=10.10.1.1 routing-mark=to_ISP1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.10.2.1 routing-mark=to_ISP2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.10.3.1 routing-mark=to_ISP3 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.10.1.1 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.10.2.1 distance=2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.10.3.1 distance=3 check-gateway=ping


    / ip firewall nat
    add action=accept chain=pre-hotspot disabled=no dst-address-type=!local hotspot=auth
    add chain=srcnat out-interface=ether1 action=masquerade
    add chain=srcnat out-interface=ether2 action=masquerade
    add chain=srcnat out-interface=ether3 action=masquerade

Compartir esta página