Balanceo de Carga PCC de 2, 3, 4 o más líneas de Internet con Mikrotik (load balance)

Tema en 'Manuales Ryohnosuke' iniciado por ryohnosuke, 8 Ene 2012.

  1. diego_pato2000

    diego_pato2000 New Member

    Me Gusta recibidos:
    1
    puede ser problemas de dns, cache, etc.
     
  2. Kevin Pacco

    Kevin Pacco New Member

    Me Gusta recibidos:
    0
    la verdad una WAN es de Telefonica y la otra de Bitel, en cuanto a DNS, estoy usando los de google 8.8.8.8 y 8.8.4.4
     
  3. diego_pato2000

    diego_pato2000 New Member

    Me Gusta recibidos:
    1
    Pero aparte de los de google, agregale los del proveedor, y tambien ver si las wan son por dhcp, desactivar los dns
     
  4. Astor Rivera

    Astor Rivera New Member

    Me Gusta recibidos:
    0
    Buenas soy nuevo en el foro. Una pregunta si creo una queue tree para limitar digamos a un usuario con 1 mb. Mis 2 lineas son de 3mb balanceadas Como trabajaría ese queue en ese caso
     
  5. diego_pato2000

    diego_pato2000 New Member

    Me Gusta recibidos:
    1
    acá está bien explicado, independientemente de cuantas wan tengas
     
    A Astor Rivera le gusta esto.
  6. Astor Rivera

    Astor Rivera New Member

    Me Gusta recibidos:
    0
    Si eso lo entiendo solo es una duda de como es q ese queue tree trabajaría ya q el usuario que le asigne un mega tiene dos dispositivos conectados a ese queue y mi red es balanceada con 2 lineas como funcionaria
     
  7. Cesar9999

    Cesar9999 New Member

    Me Gusta recibidos:
    0
    Buenos dias
    Tengo un balanceo de carga con PPPoE cliente router bridge de movistar,dos lineas de 15.
    En mi caso cuando inicia el balanceo todo bien en la navegación ya que la LAN sube hasta 29-30 Mbps
    Pero dentro de unos minutos la velocidad empieza a degradar y la velocidad no pasa de 15 pero trabajan las dos lineas
     
  8. diego_pato2000

    diego_pato2000 New Member

    Me Gusta recibidos:
    1
    Podes mandar una imagen de como lo tenés configurado. El ppoe lo hace el mkt?.
     
  9. Cesar9999

    Cesar9999 New Member

    Me Gusta recibidos:
    0
    bueno lo tengo configurado de esta manera


    /interface ethernet
    set [ find default-name=ether1 ] mac-address=4C:5E:0C:C0:6B:02
    set [ find default-name=ether2 ] mac-address=4C:5E:0C:C0:6B:03
    set [ find default-name=ether3 ] mac-address=4C:5E:0C:C0:6B:04
    set [ find default-name=ether4 ] mac-address=4C:5E:0C:C0:6B:05
    set [ find default-name=ether5 ] mac-address=4C:5E:0C:C0:6B:06
    /interface pppoe-client
    add disabled=no interface=ether1 max-mru=1480 max-mtu=1480 name=pppoe-out1 \
    password=speedy user=speedy
    add disabled=no interface=ether2 max-mru=1480 max-mtu=1480 mrru=1600 name=\
    pppoe-out2 password=speedy user=speedy
    /tool user-manager customer
    set admin access=\
    own-routers,own-users,own-profiles,own-limits,config-payment-gw
    /ip address
    add address=192.168.5.1/24 interface=ether2 network=192.168.5.0
    /ip dns
    set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
    /ip firewall mangle
    # pppoe-out1 not ready
    add action=mark-connection chain=prerouting connection-state=new in-interface=\
    pppoe-out1 new-connection-mark=pppoe-out1_conn
    # pppoe-out2 not ready
    add action=mark-connection chain=prerouting connection-state=new in-interface=\
    pppoe-out2 new-connection-mark=pppoe-out2_conn
    add action=mark-routing chain=output connection-mark=pppoe-out1_conn \
    new-routing-mark=to_pppoe-out1
    add action=mark-routing chain=output connection-mark=pppoe-out2_conn \
    new-routing-mark=to_pppoe-out2
    add action=mark-connection chain=prerouting connection-state=new \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    pppoe-out1_conn per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting connection-state=new \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    pppoe-out2_conn per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting connection-mark=pppoe-out1_conn \
    in-interface=ether5 new-routing-mark=to_pppoe-out1
    add action=mark-routing chain=prerouting connection-mark=pppoe-out2_conn \
    in-interface=ether5 new-routing-mark=to_pppoe-out2
    /ip firewall nat
    # no interface
    add action=masquerade chain=srcnat out-interface=pppoe-out1
    # no interface
    add action=masquerade chain=srcnat out-interface=pppoe-out2
    /ip route
    add distance=1 gateway=pppoe-out1 routing-mark=to_pppoe-out1
    add distance=1 gateway=pppoe-out2 routing-mark=to_pppoe-out2
    add distance=2 gateway=pppoe-out2
    add disabled=yes distance=1 gateway=pppoe-out1
     
  10. diego_pato2000

    diego_pato2000 New Member

    Me Gusta recibidos:
    1
    ok lo veo bien, pero porque no pones en las rutas la misma distancia a todas y desde las mangle le decis por cual wan salir determinado grupo
     
  11. josuesystema

    josuesystema Member

    Me Gusta recibidos:
    0
    Buen dia Chicos acabo de hacer un balanceo con 5 lineas iguales de 10 mega peero ahora solo me esta saliendo trafico por una sola linea, si pueden ayudarme por favor

    aqui pongo el scrip k ultilice

    /ip address
    add address=192.168.10.1/24 network=192.168.10.0 broadcast=192.168.0.255 interface=Local
    add address=192.168.7.2/24 network=192.168.7.0 broadcast=192.168.7.255 interface=WAN1
    add address=10.0.6.5/24 network=10.0.6.0 broadcast=10.0.6.255 interface=WAN2
    add address=10.0.5.5/24 network=10.0.5.0 broadcast=10.0.5.255 interface=WAN3
    add address=10.0.1.5/24 network=10.0.1.0 broadcast=10.0.1.255 interface=WAN4
    add address=10.0.0.5/24 network=10.0.0.0 broadcast=10.0.0.255 interface=WAN5
    add address=10.0.2.5/24 network=10.0.2.0 broadcast=10.0.2.255 interface=WAN7
    /ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=8.8.8.8
    /ip firewall mangle

    add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn
    add chain=input in-interface=WAN3 action=mark-connection new-connection-mark=WAN3_conn
    add chain=input in-interface=WAN4 action=mark-connection new-connection-mark=WAN4_conn
    add chain=input in-interface=WAN5 action=mark-connection new-connection-mark=WAN5_conn
    add chain=input in-interface=WAN7 action=mark-connection new-connection-mark=WAN7_conn
    add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2
    add chain=output connection-mark=WAN3_conn action=mark-routing new-routing-mark=to_WAN3
    add chain=output connection-mark=WAN4_conn action=mark-routing new-routing-mark=to_WAN4
    add chain=output connection-mark=WAN5_conn action=mark-routing new-routing-mark=to_WAN5
    add chain=output connection-mark=WAN7_conn action=mark-routing new-routing-mark=to_WAN7
    add chain=prerouting dst-address=10.0.6.0/24 action=accept in-interface=Local
    add chain=prerouting dst-address=10.0.5.0/24 action=accept in-interface=Local
    add chain=prerouting dst-address=10.0.1.0/24 action=accept in-interface=Local
    add chain=prerouting dst-address=10.0.0.0/24 action=accept in-interface=Local
    add chain=prerouting dst-address=10.0.2.0/24 action=accept in-interface=Local
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:5/0 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:5/1 action=mark-connection new-connection-mark=WAN3_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:5/2 action=mark-connection new-connection-mark=WAN4_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:5/3 action=mark-connection new-connection-mark=WAN5_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:5/4 action=mark-connection new-connection-mark=WAN7_conn passthrough=yes
    add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2
    add chain=prerouting connection-mark=WAN3_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN3
    add chain=prerouting connection-mark=WAN4_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN4
    add chain=prerouting connection-mark=WAN5_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN5
    add chain=prerouting connection-mark=WAN7_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN7
    /ip route

    add dst-address=0.0.0.0/0 gateway=10.0.6.1 routing-mark=to_WAN2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.0.5.1 routing-mark=to_WAN3 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.0.1.1 routing-mark=to_WAN4 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.0.0.1 routing-mark=to_WAN5 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.0.2.1 routing-mark=to_WAN7 check-gateway=ping

    add dst-address=0.0.0.0/0 gateway=10.0.6.1 distance=2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.0.5.1 distance=3 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.0.1.1 distance=4 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.0.0.1 distance=5 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.0.2.1 distance=5 check-gateway=ping

    /ip firewall nat
    add chain=srcnat out-interface=WAN2 action=masquerade
    add chain=srcnat out-interface=WAN3 action=masquerade
    add chain=srcnat out-interface=WAN4 action=masquerade
    add chain=srcnat out-interface=WAN5 action=masquerade
    add chain=srcnat out-interface=WAN7 action=masquerade

    vip.163.com
     
  12. diego_pato2000

    diego_pato2000 New Member

    Me Gusta recibidos:
    1
    en mi caso dejo todas las distancias en 1, o sea iguales, y desde la mangle creo grupos y les digo por cual wan salir y listo.
    Fijate si te sirve
     

Compartir esta página