Conseguir pasar trafico multicast en enlace mikrotik

Tema en 'Sistemas PPP' iniciado por davidn70mo, 2 Ene 2015.

  1. davidn70mo

    davidn70mo Member

    Me Gusta recibidos:
    7
    Ok,gracias,preparo el diagrama y lo cuelgo
     
  2. davidn70mo

    davidn70mo Member

    Me Gusta recibidos:
    7
    Este es el diagrama
    [​IMG]

    Y esta la configuracion de la rb450.
    Insertar CODE, HTML o PHP:
    /interface ethernet
    set 0 name=ether1-gateway
    set 1 name=ether2-master-local
    set 2 master-port=ether2-master-local name=ether3-slave-local
    set 3 master-port=ether2-master-local name=ether4-slave-local
    set 4 master-port=ether2-master-local name=ether5-slave-local
    /interface vlan
    add interface=ether1-gateway l2mtu=1594 name=vlan3 vlan-id=3
    add interface=ether1-gateway l2mtu=1594 name=vlan6 vlan-id=6
    add interface=ether1-gateway l2mtu=1594 name=vlan2 vlan-id=2
    /interface pppoe-client
    add add-default-route=yes allow=pap,chap disabled=no interface=vlan6 \
        max-mru=1492 max-mtu=1492 name=pppoe-out1 password=adslppp \
        use-peer-dns=yes user=adslppp@telefonicanetpa
    /ip pool
    add name=dhcp ranges=192.168.1.201-192.168.1.249
    add name=vpn ranges=192.168.3.10-192.168.3.20
    /ip dhcp-server
    add address-pool=dhcp disabled=no interface=ether2-master-local name=dhcp1
    /ppp profile
    set 1 dns-server=192.168.3.250 local-address=192.168.3.250 remote-address=vpn
    /interface pptp-server server
    set authentication=mschap2 enabled=yes
    /ip address
    add address=192.168.1.1/24 comment="default configuration" interface=\
        ether2-master-local
    add address=192.168.100.10/24 interface=ether1-gateway
    /ip dhcp-client
    add add-default-route=no disabled=no interface=vlan3 use-peer-ntp=no
    /ip dhcp-server option
    add code=240 name=option_para_deco value=\
        "':::::239.0.2.10:22222:v6.0:239.0.2.30:22222'"
    /ip dhcp-server network
    add address=192.168.1.0/24 dns-server=192.168.1.1 gateway=192.168.1.1 \
        netmask=24
    add address=192.168.1.199/32 dhcp-option=option_para_deco dns-server=\
        172.26.23.3 gateway=192.168.1.1 netmask=24
    /ip dns
    set allow-remote-requests=yes
    /ip dns static
    add address=192.168.1.1 name=router
    /ip firewall filter
    add chain=input comment="default configuration" protocol=icmp
    add chain=input comment="default configuration" connection-state=established
    add chain=input comment="default configuration" connection-state=related
    add chain=input disabled=yes dst-port=23,80 in-interface=pppoe-out1 protocol=\
        tcp
    add chain=input dst-port=8291 in-interface=pppoe-out1 protocol=tcp
    add chain=input dst-port=1723 in-interface=pppoe-out1 protocol=tcp
    add action=drop chain=input comment="default configuration" in-interface=\
        pppoe-out1
    add chain=forward comment="default configuration" connection-state=\
        established
    add chain=forward comment="default configuration" connection-state=related
    add action=drop chain=forward comment="default configuration" \
        connection-state=invalid
    /ip firewall mangle
    add action=set-priority chain=postrouting new-priority=4 out-interface=vlan2
    add action=set-priority chain=postrouting new-priority=4 out-interface=vlan3
    add action=set-priority chain=postrouting new-priority=1 out-interface=\
        pppoe-out1
    /ip firewall nat
    add action=masquerade chain=srcnat comment="default configuration" \
        out-interface=pppoe-out1
    add action=masquerade chain=srcnat comment="default configuration" \
        out-interface=ether1-gateway
    add action=masquerade chain=srcnat comment="default configuration" \
        out-interface=vlan2
    add action=masquerade chain=srcnat comment="default configuration" \
        out-interface=vlan3
    add action=dst-nat chain=dstnat dst-address-type=local in-interface=\
        vlan2 comment="VOD" to-addresses=192.168.1.199
    add action=dst-nat chain=dstnat disabled=yes dst-port=80 in-interface=\
        pppoe-out1 protocol=tcp to-addresses=192.168.1.125
    add action=dst-nat chain=dstnat disabled=yes dst-port=21 in-interface=\
        pppoe-out1 protocol=tcp to-addresses=192.168.1.125
    /ip route
    add distance=255 gateway=255.255.255.255
    /ip upnp
    set enabled=yes
    /ip upnp interfaces
    add interface=ether2-master-local type=internal
    add interface=pppoe-out1 type=external
    /routing igmp-proxy interface
    add alternative-subnets=0.0.0.0/0 interface=vlan2 upstream=yes
    add interface=ether2-master-local
    /routing rip interface
    add interface=vlan3 passive=yes receive=v2
    add interface=vlan2 passive=yes receive=v2
    /routing rip network
    add network=10.0.0.0/8
    add network=172.26.0.0/16
    /system clock
    set time-zone-name=Europe/Madrid
    /system ntp client
    set enabled=yes primary-ntp=163.117.202.33 secondary-ntp=\
        89.248.104.162
    
    Aqui solo falta la ip del servicio de iptv que iria colocada en la vlan2 con mascara /10
     
    Última edición por un moderador: 18 Feb 2015
  3. ALEJANDROGORDON

    ALEJANDROGORDON Well-Known Member

    Me Gusta recibidos:
    1.745
    a ya esta facil cuando estes online y yo este online dame acceso a tus equipos y podemos verlos para hacer la configuración =)
     
    A borregote360 y davidn70mo les gusta esto.
  4. davidn70mo

    davidn70mo Member

    Me Gusta recibidos:
    7
    Ok, muchas gracias, porque la verdad es que no se que hacer.
     
  5. davidn70mo

    davidn70mo Member

    Me Gusta recibidos:
    7
    Bueno mi estimado ALEJANDROGORDON, me esta ayudando a poder llevar esto a cabo y ya me ha asesorado para poder resolver mi problema, voy a seguir los consejos que me ha dado y a sustituir un switch por un rb para poder crear un tunel para separar el servicio de iptv y el de internet.

    Gracias por tu paciencia y por tus consejos, quedo muy agradecido por tu ayuda y espero terminar de llevar a cabo este proyecto con su apoyo.

    Un saludo.
     
  6. davidn70mo

    davidn70mo Member

    Me Gusta recibidos:
    7
    Bueno, pues despues de muchos dolores de cabeza, mi estimado ALEJANDROGORDON ha conseguido dar solucion al problema que tenia con el iptv, ha conseguido que consiga verlo sin saturar la red y a la misma vez, me ha aconsejado para mejorar la misma.

    Muy agradecido por prestarme sus conocimientos.

    Un saludo.
     
  7. jovadj

    jovadj Member

    Me Gusta recibidos:
    0
    Hola @ALEJANDROGORDON tengo la misma situacion me podria decir como lograste pasar el IPTV

    actuamente tengo un 450G administrando la fibra (NAT) luego pasa al servidor

    ONT AP--------ES---- 450G -------server cliente Linux
     
  8. ALEJANDROGORDON

    ALEJANDROGORDON Well-Known Member

    Me Gusta recibidos:
    1.745
    todo se reducce al uso de vlans amigo. saludos
     
  9. Alvaro Duarte

    Alvaro Duarte Member

    Me Gusta recibidos:
    10
    Buenas, me parece interesante el tema y me gustaria saber lo necesario para llevar iptv a otro punto y repartirlo si me pudieran colaborar, gracias de antemano.
     
  10. jovadj

    jovadj Member

    Me Gusta recibidos:
    0
    Hola realmente no he podido trasladar mi IP TV

    Mi diagrama es ONT--->>> MIKROTIK balanceo y control -à>> AP WDS-----à>>> ESTACION WDS ----- TERMINAL IPTV CISCO

    Como puedo pasar el tráfico de la IP TVsi que afecte el rendimiento de la red de la manera más factible

    Ayuda por favor compañero de verdad que no he podido
     
  11. Kevin Cedeno F.

    Kevin Cedeno F. Active Member

    Me Gusta recibidos:
    127
    La respuesta es utilizar VLANs, con eso consigues no saturar el L2 por el cual pasaras el servicio de IPTV, si deseas que te ayude en mi firma mis datos para que me agregues a whatsapp
     
  12. ALEJANDROGORDON

    ALEJANDROGORDON Well-Known Member

    Me Gusta recibidos:
    1.745
    como ya te habia comentado el trafico puede ser encapsulado usando vlan, sin embargo vlan tampoco es una solucion cuando el trafico es multicast ya que puedes saturar los enlaces, una solucion mas viable seria pasar el trafico a unicast y de hay puedes usarlo sin ningun problema sobre la red, acabo de realizar una configuracion, para pasar trafico ya convertido a unicast, danto internet e iptv mediante pppoe, y simple puedes diferenciar el trafico de cada servicio para dar un QOS, sin efectar ninguno de los servicios.
     
  13. jovadj

    jovadj Member

    Me Gusta recibidos:
    0
    Gracias por responder Kevin Cedeno F. , ALEJANDROGORDON

    Ok podrían darme algún ejemplo de cómo hacerlo



    Que necesitan para el ejemplo
     
  14. VictorHBotta

    VictorHBotta New Member

    Me Gusta recibidos:
    0
    Hola entre por primera vez y veo tu tema , aun estas trabajando en ello ? yo tengo andando algo muy parecido
    un encoder mpeg2 con ip 224.2.2.2 enviando multicast a un Rocket M5 y en el otro extremo otro Rocket M5 con una pc decodificando el video , me costo bastante hacerlo andar pero ya esta .Como te fue ?
     
  15. tay

    tay Member

    Me Gusta recibidos:
    8
    buen dia sala de foro
    Con este tema del multicast streamer etc..Se crea una vlan para esos servicios, se instala un switch con las vlan y esos puertos sin taggear, para que los equipos puedan conectarse en dhcp o manual.
    Ejemplo hay una rasberry que tiene embebida una emisora y la cual esta instalada en un nodo remoto. Llega una señal ip desde el enlace inalambrico.
    Ya la emisora que esta en la rasberry sacamos el audio lo amplifiiamos y enviamos FM.
     
  16. tay

    tay Member

    Me Gusta recibidos:
    8
    Buenas tardes sala de foro y Victor.
    el tema con los rockes esta bien, pero cuando pasa un trafico y satura el enlace el streamer va mal y se pixela. Estoy con unos netmetal5 y sucede que el trafico de 18mbps del bridge no se refleja en el tx de la wlan, ya en el remoto llega el streamer pixelado: Alguna idea de donde estara el cuello de botella?
    Cabe anotar que la configuracion del netmetal esta ap bridge station bridge con un trafico maximo de 70mbps full duplex. Alguien de la sala ha trabajado con el paquete multicast de mikrotik (este paquete se instala del zip npk), el que aparece como pim en la pestaña routing? gracias
     
  17. ALEJANDROGORDON

    ALEJANDROGORDON Well-Known Member

    Me Gusta recibidos:
    1.745
    si tienes mk en ese caso opta por mpls sobre el enlace.
     
  18. Meganet.arg

    Meganet.arg New Member

    Me Gusta recibidos:
    0
    justamente eso mismo te estaba por comentar Metes una vlan desde la entrada y le vas dando salida a esa vlan limitandole por ej 10 o 15 M para que no sature a su vez y dandole una prioridad baja.. Y solo los clientes que quieren el serviciod e ip tv le cargas la vlan en su antena.. listo.. resuelto.
     
  19. tay

    tay Member

    Me Gusta recibidos:
    8
    buenas tardes sala de foro, gracias Alejandro.
    Ese tema de mpls nunca lo he implementado. La red que tengo esta en Ospf, podrias darme una sugerencia? Es suficiente con crear una vlan para que ese trafico multicast no se mezcle con otras redes y rantelice el ancho de banda? estamos atentos buen dia.
     
  20. tay

    tay Member

    Me Gusta recibidos:
    8
    Buenas Meganet, que pena no habia leido bien su mensaje, voy a tomar la sugerencia tambien y voy a probar y les comento, muchas gracias.
     

Compartir esta página