quien conoce thundercache

Tema en '[ThunderCache] Otros Sistemas' iniciado por Jesus Enmanuel Fereras, 28 Oct 2014.

  1. Jesus Enmanuel Fereras

    Jesus Enmanuel Fereras Member

    Me Gusta recibidos:
    3
    tengo instalado squid 3.19
    apache
    mysql
    y php
    mas thundercache 1b, la cuestion es que no me navegan los clientes, alquien sabe algo, me podria dar l

    mi configuracion es la siguiente:
    he instalado thundercache sin problema en xubuntu 12.4 64 bit, pero tengo varias preguntas

    1- el servidor que estoy utilizando para mikrotik es una laptop por lo tanto solo tengo una sola interfaz de red(disponible para salidad de internet)(interfaz de red eth1)
    2- el servidor thunder solo le he instalado una sola tarjeta de red(interfaz de red eth0)

    esta es mi configuracion

    Red:
    192.168.0.1/23
    255.255.254.0
    gateway=192.168.0.1
    servidor miktrotik (interfaz de red eth1)

    ThunderCache 192.168.02 (interfaz de red eth0)
    Ip para mis clientes 192.168.0.100-192.168.1.254

    nota: el rango de ip 192.168.0.2-192.168.0.99(están reservadas para AP)

    la configuracion que quiero es por Manglare como la que tiene publicada


    Ejemplo de regla Ip tables:
    #!/bin/bash
    echo ";;;;;;;;;;;;;;;;;;;;;;;"
    echo "; thundercache ;"
    echo ";;;;;;;;;;;;;;;;;;;;;;;"

    #Borrar cadenas anteriores
    iptables -F
    iptables -X
    iptables -Z
    iptables -t nat -F

    #Condiciones por defecto
    iptables -P INPUT ACCEPT
    iptables -P OUTPUT ACCEPT
    iptables -P FORWARD ACCEPT

    iptables -t nat -P PREROUTING ACCEPT
    iptables -t nat -P POSTROUTING ACCEPT

    #Aceptamos el localhost
    iptables -A INPUT -i lo -j ACCEPT

    #Aceptamos la red local
    iptables -A INPUT -s 192.168.0.0/23 -j ACCEPT

    iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128

    echo 1 > /proc/sys/net/ipv4/ip_forward

    Con esta configuracion no me navegan los clientes
    cambiando esta regla
    iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128
    para navegar he cambiado esta regla, pero no hace cache y navega lento

    iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j REDIRECT --to-port 3128

    Reglas para miktrotik

    /ip route
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.0.2 routing-mark=raptor_route scope=30 target-scope=10
    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="thunder - Mangle ====================>" disabled=no dst-port=80 in-interface=ether1 new-routing-mark=raptor_route passthrough=no protocol=tcp
    add action=mark-connection chain=forward comment="== thundercache ==" content="X-Cache: HIT from thunder" disabled=no new-connection-mark=thunder-connection passthrough=yes
    add action=mark-packet chain=forward connection-mark=thunder-connection disabled=no new-packet-mark=thunder-packs passthrough=no
    add action=mark-connection chain=forward comment="==SQUID - TOS 12==" disabled=no dscp=12 new-connection-mark=squid-connection passthrough=yes
    add action=mark-packet chain=forward connection-mark=squid-connection disabled=no new-packet-mark=squid-packs passthrough=yes
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=4M name="thundercache" packet-mark=thunder-packs parent=global-out priority=4 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=4M name="Squid 3.x" packet-mark=squid-packs parent=global-out priority=4 queue=default

    pregunta: tendría que cambiar el servidor mikrotik(por un RB) ya que solo tengo una tarjeta de red disponible para salida de Internet, ya que la configuración que tengo no me esta funcionando, no hace cache, ni nada por es estilo

    los clientes no salen a internet

    sugerencias

    gracias por su tiempo
     

Compartir esta página