[Workaroud] Speedtest.net y ThunderCache (no hace caché)

Tema en '[ThunderCache] Soporte Técnico' iniciado por ryohnosuke, 30 May 2014.

  1. ryohnosuke

    ryohnosuke MikroTik Support Guy Administrador

    Me Gusta recibidos:
    604
    Desde ya hace varios meses se ha comprobado que algunos servidores de Speedtest.net utilizan el puerto 8080 TCP para hacer el test de velocidad, esto quiere decir que ThunderCache no será capaz de entregar "Full Caché" ya nuestra versión actual sólo maneja tráfico HTTP a través del puerto 80 TCP.

    Se ha demostrado en nuestras pruebas que aquellos servidores de Speedtest que utilizan por defecto el puerto 8080 TCP también tienen soporte a través de HTTP standard pero únicamente para las aplicaciones de celulares y cuando el test comprueba que el puerto 8080 está bloqueado.

    La versión más antigua del workaround solo consistía el bloquear el puerto 8080 TCP completamente, pero traía algunos problemas con páginas del tipo http://abc:8080 u otros servicios que dependen de este puerto.

    Ayer recién me animé a probar un script más detallado para bloquear las conexiones al puerto 8080 TCP que hace Speedtest dando hasta el momento bonitos resultados. :)



    Aprovechando una conexión de verificación.

    Speedtest lanza siempre una conexión al puerto 843 TCP, justamente el servidor que recibe esa conexión es el mismo servidor al que se hace la conexión al puerto 8080, así que lo aprovecharemos para bloquear su conexión.

    CODE, HTML o PHP Insertado:
    /ip firewall mangle
    add chain=prerouting dst-port=843 in-interface=LAN protocol=tcp action=add-dst-to-address-list address-list=speedtest8080 address-list-timeout=10m
    CODE, HTML o PHP Insertado:
    /ip firewall filter
    add action=drop chain=forward dst-address-list=speedtest8080 dst-port=8080 in-interface=LAN protocol=tcp


    Tengan en cuenta que lo que se hace aquí es bloquear la conexión del cliente al servidor:8080 , así que se pueden utilizar otros criterios para hacerlo utilizando estos 2 métodos como BASE, en este caso sólo estamos especificando el in-interface=LAN, donde "LAN" es la interfaz de los clientes.


    Si tuvieran algún problema con esta implementación, pueden abrir un ticket desde el área de clientes de http://thundercache.es/

    Saludos.
     
  2. rodri20

    rodri20 Member

    Me Gusta recibidos:
    0
    Cuando una guia para que el https de youtube pasa por TC7 :/
     
  3. ryohnosuke

    ryohnosuke MikroTik Support Guy Administrador

    Me Gusta recibidos:
    604
    Espero que en este mes que viene! ;)

    Saludos.
     
    A hecave3105 le gusta esto.
  4. Pipipo

    Pipipo New Member

    Me Gusta recibidos:
    2
    Tu comentario totalmente fuera de lugar, hasta la fecha no tengo problemas con mi servidor, ahora con thundercache puedo mostrarles a mis clientes la velocidad que ayude vender mis servicios, cosa que me ayuda bastante y creo que a muchos. Si no te es utíl ¿porque no buscas otra alternativa o contratas más velocidad?
     
  5. ryohnosuke

    ryohnosuke MikroTik Support Guy Administrador

    Me Gusta recibidos:
    604
    Bueno, en realidad se entiende el comentario, ya que también estoy esperando la actualización para hacer cache de YouTUBE!!!!

    Saludos.
     
    A frankdemo2 le gusta esto.
  6. sadoreg

    sadoreg Member

    Me Gusta recibidos:
    11
    Amigo simplemente esta haciendo una pregunta, no veo tanta agresion para decirle "TU COMENTARIO ESTA FUERA DE LUGAR"... es licito que pregunte la solución al problema actual del thuder, el mismo ryo indica que esta a la espera, como que el tema del thunder esta siendo demasiado sensible, es lo que creo
     
  7. frankdemo2

    frankdemo2 Member

    Me Gusta recibidos:
    12
    No tanto que este fuera de lugar, ya que si es cierto que los videos de youtube en https no se cachean por ende por esa parte no podemos entregar un buen fullcache, lo del speed test ya lo resolvio Carlos, esperamos lo de los https
    Saludos
     
  8. Pipipo

    Pipipo New Member

    Me Gusta recibidos:
    2
    Disculpa pero creo que es bastante obvio tu comentario, asi que simple pregunta no es,si te pongo que: tu comentario totalmente fuera de lugar, es porque algo que no tiene nada que ver con el speedtest para hacer pruebas de velocidad, tienes otras secciones en el foro donde puedes hacer tu "simple pregunta" de manera correcta, el soporte para https que como tu o como todos no se veia llegar tan rápido, pero ya esta y leo todos los días que estan trabajando en ello, y vuelvo a repetir, si esta herramienta no es de tu ayuda, opta por otras o contrata más ancho de banda.

    Nada es peor que hacer leña del abrol caido, de algo que es tu única alternativa (¿si no porque sigues hablando del mismo tema?), porque eso refleja en aquellas personas que repiten de cada 10 mensajes que tienen, 9 son que thundercache tiene esto, thundercache tiene lo otro, etc
     
    Última edición: 31 May 2014
  9. Pipipo

    Pipipo New Member

    Me Gusta recibidos:
    2
    Claro, todos esperamos lo mismo, tengo entendido que los programas más comerciales que leí en el foro, no hacen cache al puerto 443=https, pero no creo que sea sano hacer la "simple pregunta" en cada tema o si? ya que si fuera una simple guía, creo que el amigo ryohnosuke hace tiempo lo habría echo.
     
    Última edición: 31 May 2014
    A hecave3105 le gusta esto.
  10. sadoreg

    sadoreg Member

    Me Gusta recibidos:
    11
    Agrego que debiste decir "PARA MI TU COMENTARIO ESTA FUERA DE LUGAR", debido a que hay personas que pueden ver que el tema esta relacionado con lo expuesto, y una prueba de ello es que frankdemo2 y ryo hayan respondido a su comentario.
    Según tu no crees que sea sano repetir una misma pregunta, pero esa es tu opinión y la respetamos, lo que se crítica es las formas amigo, si existe personas que tienen alguna duda, simplemente se indica con mucha educación que esa pregunta se ha respondido o no tiene respuesta. Pero creo que pedir educación es, en estos días, ya un absurdo, lo unico que reconforta y agradace es que ryohnosuke haya respondido a su "comentario fuera de lugar"
     
  11. ryohnosuke

    ryohnosuke MikroTik Support Guy Administrador

    Me Gusta recibidos:
    604
    Para mí también está fuera de lugar :v, pero se entiende la ansiedad que se vive con esto de YouTUBE + HTTPS.

    Saludos.
     
  12. sadoreg

    sadoreg Member

    Me Gusta recibidos:
    11
    Ese es el punto que respondas con mucha eduación, no que defrente te meta un rodillazo
     
  13. ryohnosuke

    ryohnosuke MikroTik Support Guy Administrador

    Me Gusta recibidos:
    604
    Bueno hombre, tampoco para tanto; osea, para mí es sólo un comentario, yo también suelo escribir así, bastante duro, cuando necesitas llamar la atención a alguien, y no necesariamente es ser agresivo.

    Saludos.
     
  14. Pipipo

    Pipipo New Member

    Me Gusta recibidos:
    2
    creo que fue un error de mi parte citarte, aclaro que todo el contenido no es para ti sino para el primer comentario, nunca falto el respeto, pero como toda regla en un foro es no desviar el tema principal, y si tienes otros temas por hablar puedes crear uno propio, pero no crees que es puntapie decir: para cuando una "guía" para que pase por https? sabiendo que no es nada facil, imagino como estaran esos programadores buscando una solución y nosotros en ascuas, esperemos pero aportando algo.

    Nota mis respuestas son personales, tiene relación a lo expuesto? si! pero no es el lugar. Si algún moderador puede borrar o mover mis comentarios que no van con el tema mucho mejor, cerrando la discusión.
     
  15. Pipipo

    Pipipo New Member

    Me Gusta recibidos:
    2
    Tengo una gran duda, ¿que es workaround? y es seguro que el speedtest solo salga por los puertos ¿8080 y 80?, ¿no varia del lugar hagamos el test?.
     
  16. ryohnosuke

    ryohnosuke MikroTik Support Guy Administrador

    Me Gusta recibidos:
    604
    La solución real sería hacer caché del puerto 8080, pero si bloqueo el puerto 8080 de Speedtest, el resultado final será el mismo, o casi el mismo que la solución real, eso es un "workaround". No es una solución real, pero es efectiva como medida temporal.

    He probado varios servidores de Speedtest, y sólo usan el puerto 80 o el 8080; ya si se llegara ver que usa otros puertos, se tendría que hacer modificaciones a este workaround.

    Saludos.
     
  17. athlonxp78

    athlonxp78 New Member

    Me Gusta recibidos:
    1
    Gracias ryo!!!

    Funciona PER-FEC-TO ;)
     
  18. rgear13

    rgear13 Active Member

    Me Gusta recibidos:
    43
    hola ryo,

    he estado probando el código de layer7 pero no funciona y el metodo 2 si me va pero no me gusta la idea de colocar la regla por encima de todas ya de otra manera no funciona ademas de que mis ips publicas van al address list, alguna sugerencia?
     
  19. janddo

    janddo Well-Known Member

    Me Gusta recibidos:
    84
    Hola @ryohnosuke , gracias por el aporte, solo quiero hacer una consulta, en que parte de las reglas mangle y filter deberían ir posicionados estas reglas.. gracias por tu pronta respuesta....
     
  20. ALEJANDROGORDON

    ALEJANDROGORDON Well-Known Member

    Me Gusta recibidos:
    1.705
    amigo ya hay post hablandose de esto por favor evita desvirtuar este post, Gracias
     

Compartir esta página