[Tutorial] Configurar Full Cache para v5.x y v6.x de RouterOS (Mikrotik)

Tema en '[ThunderCache] Instalación & Configuración' iniciado por SaiToX87, 4 Feb 2014.

  1. SaiToX87

    SaiToX87 Active Member

    Me Gusta recibidos:
    47
    El muy conocido FullCache, que hará que todo el contenido que salga del disco duro de nuestro servidor vaya a una velocidad superior al límite impuesto a nuestros clientes.

    Si bien un cliente puede tener 256 kbps de bajada como limitación, con FullCache podremos hacer que este cliente ingnore lo mimitado y alcance la velocidad establecida.

    Solo tienen que agregar estos comandos desde el "New Terminal".

    Para la versión V5.x de RouterOS

    Insertar CODE, HTML o PHP:
    /ip firewall mangle
    add action=mark-packet chain=postrouting dscp=18 new-packet-mark=fullcache passthrough=no
    1. Donde el valor 18 es el valor DSCP que ThunderCache utiliza por defecto para marcar todo el tráfico saliente del caché.
    Una vez marcados los paquetes, sólo tendremos que darle uso a esa marca, en el Queue Tree.


    [​IMG] - [​IMG] - [​IMG]



    Insertar CODE, HTML o PHP:
    /queue tree
    add name=fullcache packet-mark=fullcache parent=global-out priority=8 max-limit=5M queue=default
    2. Donde 5M quiere decir la velocidad máxima que tendrán los elementos que salgan del cache (uno puede colocar el límite que crea conveniente).

    [​IMG]


    Para la versión V6.x de RouterOS


    Insertar CODE, HTML o PHP:
    /ip firewall mangle
    add action=mark-packet chain=postrouting dscp=18 new-packet-mark=fullcache passthrough=no
    1. De igual forma iniciamos con la regla para marcar los paquetes.

    [​IMG] - [​IMG] - [​IMG]



    Insertar CODE, HTML o PHP:
    /queue simple
    add max-limit=2M/5M name=fullcache packet-marks=fullcache target="0.0.0.0/0"
    2. Pero en vez de crear una Queue Tree, lo reemplazamos por una Simple Queues, en esta caso le puse un nombre de referencia, marcando el paquete de fullcache con 2M hasta 8M.

    [​IMG]


    3. Este Scheduler lo agrego, para poner en primer lugar la regla fullcache y para aquellos que tienen más de una Simple Queues.

    Insertar CODE, HTML o PHP:
    /system scheduler
    add interval=10s name=fullcache on-event="/queue simple move [/queue simple \
        find name=\"fullcache\"] [:pick [find] 0]" policy=\
        ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
        start-time=startup
    4. Este Scheduler lo agrego, para poner en primer lugar la Simple Queues cada 10 segundos (necesario para quienes tengan más de una Simple Queues).

    [​IMG]

    Preguntas y respuestas

    ¿Porque el fullcache no entrega los 50M que yo configure?
    Rpta.: Tener en cuenta que lo que configura es el MIR o más conocido como el Max Limit, quiere decir que es la velocidad máxima que entregara (en nuestro ejemplo 5M) el cache es de 0M a 5M.

    ¿Si tengo clientes de forma inalámbrica, hasta cuanto Megas puedo configurar?
    Rpta.: Esto depende de tus nodos y cantidad de antenas base, lo recomendable es 4M.

    ¿Si tengo mi red solo por cableado hasta cuanto puedo configurar?
    Rpta.: Si en tu red tienes tarjetas de red y switch fast ethernet (10/100) hasta 80M.

    ¿Que pasa si olvido crear el Scheduler?
    Rpta.: La regla funcionara, pero le tocara activarse en el orden que este.

    ¿Si no limito a mis usuarios y solo tengo una red cableada tengo que configurar todo esto?
    Rpta.: No, en esos caso no es necesario.
     
    Última edición por un moderador: 18 Feb 2015
    A Luna Barrera, Pipipo y Adrian les gusta esto.
  2. Mateito

    Mateito Active Member

    Me Gusta recibidos:
    54
    esta buena la guia.

    Saludos

    Mateito
     
  3. ALEJANDROGORDON

    ALEJANDROGORDON Well-Known Member

    Me Gusta recibidos:
    1.743
    tambien deberian aclarar las desventajas que podria provocar el full cache si se libera una gran velocidad
     
  4. 07350286

    07350286 Active Member

    Me Gusta recibidos:
    142
    Que desventajas tienen al liberar el cache a una velocidad maxima por ejemplo 50M
     
    A elviuss le gusta esto.
  5. madarajackk

    madarajackk Active Member

    Me Gusta recibidos:
    16
    Buena guía, disculpa esta regla debe ir primera en la queue simple :confused:.

    /queue simple
    add max-limit=2M/8M name=thunderfull packet-marks=fullcache target=""
     
  6. ALEJANDROGORDON

    ALEJANDROGORDON Well-Known Member

    Me Gusta recibidos:
    1.743
    la desventaja de liberar si entiendo bien a 50 mb por usuario seria tener un cuello de botella en tus aps y si es tener 50 mb total y tu interface tiene 100 y y si un multipunto solo logra 20mb saca cuentas y dime si es efeciente
     
  7. KingDorji

    KingDorji Member

    Me Gusta recibidos:
    2
    hice todo lo que se dice aqui y no me funciona. gracias me gustaria revisaran por teamview
     
  8. KingDorji

    KingDorji Member

    Me Gusta recibidos:
    2
    sigo probando la guia muy bien explicada al parecer el burrrrro soy yo porke voy para un dia completo casi dos dia y noche y el Mk V6.9 nada de fullcache:mad:
     
  9. ALEJANDROGORDON

    ALEJANDROGORDON Well-Known Member

    Me Gusta recibidos:
    1.743
    en ves de usar forward usa postrouting y deberia funcionar, por cierto esto solo en la v6.
     
  10. ALEJANDROGORDON

    ALEJANDROGORDON Well-Known Member

    Me Gusta recibidos:
    1.743
    Insertar CODE, HTML o PHP:
    /ip firewall mangle
    add action=mark-packet chain=postrouting dscp=18 new-packet-mark=fullcache passthrough=no
    esa es la corrección de la regla.
     
    A alexemv le gusta esto.
  11. ryohnosuke

    ryohnosuke MikroTik Support Guy Administrador

    Me Gusta recibidos:
    643
    Sí, debe ser la primera regla del Simple Queue. Ten en cuenta que el script de scheduler se encargará que esa regla siempre esté arriba, esto para los que usan control de velocidad por hotspot, o pppoe.

    Saludos.
     
  12. ryohnosuke

    ryohnosuke MikroTik Support Guy Administrador

    Me Gusta recibidos:
    643
    Ya lo solucionaron desde el área de clientes, ciertamente no estaba como el manual, en especial por ese PCQ que tenías en Queue Type...

    Saludos.
     
  13. SaiToX87

    SaiToX87 Active Member

    Me Gusta recibidos:
    47
    Estimados

    Editado para no tener inconvenientes ... pero dejo una aclaración.

    Saludos.


    Forward -> marca los paquetes durante el ruteo.

    Postrouting -> marca los paquetes después del ruteo.
     
    Última edición: 1 Abr 2014
  14. ALEJANDROGORDON

    ALEJANDROGORDON Well-Known Member

    Me Gusta recibidos:
    1.743
    saitox87 en la v5 se usa forward solo en la v6 se usa postrouting
     
  15. madarajackk

    madarajackk Active Member

    Me Gusta recibidos:
    16
    Diculpa, yo lo tengo trabajando en modo bridge y no hace full cache, solo tengo esas reglas, tengo la version 6.9 :(
     
  16. KingDorji

    KingDorji Member

    Me Gusta recibidos:
    2
    Gracias. una pregunta cual es la velocidad ideal que se le puede asignar al thundercache para no crear cuellos de botella. gracias de nuebo. quiero visitar peru especialmente lima donde estan ustedes
     
  17. ALEJANDROGORDON

    ALEJANDROGORDON Well-Known Member

    Me Gusta recibidos:
    1.743
    =====000000000000 pero no todos somos de peru jejejeje y pues la velocidad ideal depende de tu red
     
  18. WAros

    WAros Member

    Me Gusta recibidos:
    7
    Hago una anotación uso v.5 y la verdad cno forward no me funciona al full cache con postrouting si, solo dejo el comentario

    saludos
     
  19. foncho

    foncho Member

    Me Gusta recibidos:
    1
    Gracias me sirvio mucho tu comentario, igualmente tengo v5 y note bastante cambio en velocidad al cambiar a postrouting.
     
  20. WAros

    WAros Member

    Me Gusta recibidos:
    7
    Pues ese detalle depende el troughput de tus multipuntos; yo uso 10 megas me da miedo saturar mis enlaces de 2.4 Ghz;

    saludos
     

Compartir esta página